2007 S550 Transmission Problems - Mercedes-Benz Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 01-22-2011, 06:47 PM
BenzWorld Newbie
 
Date registered: Mar 2009
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Post 2007 S550 Transmission Problems

I have an '07 S550 that I bought new on April 2007. It now has 54,000 miles, so it's out of the base warranty. I've had a transmission problem that has rccurred 3 times now. Here's the scenario: I'm driving at a constant speed of 50-70 mph and I'll step on the gas to pass another car or a pending red light. After a few miles I notice that the car seems stuck in a low gear. When I step on the gas, the car revs to 2000 or 3000 rpm, but it does not go very fast. The solution is to pull over, put the car in park, turn it off, wait 30 seconds and then restart the vehicle. The transmission then seems to "re-set" itself and all is fine.

What is going on here? I've had all the relevant service, including a transmission fluid change about 7k miles ago. I'm afraid to ask the dealer what this will cost to repair. Any insight is appreciated, but I may have to pay the $4k needed to buy the extended warranty cause I plan to keep this car around for many years. Thanks.

2007 S550
Newport Beach, CA
Fletcher Jones Mercedes Purchased and Serviced

Last edited by jettinaround; 01-22-2011 at 06:49 PM. Reason: spelling
jettinaround is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 01-22-2011, 11:01 PM
BenzWorld Elite
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: S320 (W220) and Zotye 1.3/Rolls Royce on back order (LOL)
Location: Jiangsu province China
Posts: 48,370
Mentioned: 3 Post(s)
Tagged: 2 Thread(s)
Quoted: 32 Post(s)
You should think seriously about the extended warranty as the normal repair for this problem is a new valve body and control unit, very expensive fix.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
#3 (permalink) Old 01-24-2011, 04:59 PM
BenzWorld Member
 
Date registered: Aug 2010
Vehicle: S550, 2006 Range Rover Superchared
Location: New Jersey
Posts: 82
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
You should have your local dealer check it out, A rebuilt tranny would cost you some serious $$$

famous550 is offline  
#4 (permalink) Old 01-26-2011, 03:53 PM
BenzWorld Member
 
MBS430's Avatar
 
Date registered: Oct 2005
Vehicle: S550, S430
Location: Portland - Oregon
Posts: 85
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
which MY has valve body issue with its 722.9 transmission?

this valve body issue sounds rather common on 722.9 transmission.

does anyone know if this issue isolated in certain manufacture year or just a matter of mileage?
MBS430 is offline  
#5 (permalink) Old 01-27-2011, 01:57 PM
BenzWorld Junior Member
 
Date registered: Feb 2010
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I have the same problem too.. 07 s550 108,000 km
Mine started last fall but i decided not to do anything about it since i planned on parking my car over the winter. (i live in Canada).
I will be taking to the dealership to have them look at it come spring...

I did some research and it is a common problem but there is no recall.

There seems to be some kind of solution acording to this thread.
http://www.benzworld.org/forums/w221...nsmission.html

Problem Solved!

--------------------------------------------------------------------------------

The dealership reprogrammed the software on the 7 G-tronic once again. This time, they changed the transmission fluid and the transmission filter. Happy to report that the problem is finally solved. The car runs as new. Thanks all for your concern.

Hopefully this helps.
Try it and Please let me know how it goes.
blssd_1 is offline  
#6 (permalink) Old 01-27-2011, 04:59 PM
BenzWorld Elite
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: S320 (W220) and Zotye 1.3/Rolls Royce on back order (LOL)
Location: Jiangsu province China
Posts: 48,370
Mentioned: 3 Post(s)
Tagged: 2 Thread(s)
Quoted: 32 Post(s)
Quote:
Originally Posted by blssd_1 View Post
I have the same problem too.. 07 s550 108,000 km
Mine started last fall but i decided not to do anything about it since i planned on parking my car over the winter. (i live in Canada).
I will be taking to the dealership to have them look at it come spring...

I did some research and it is a common problem but there is no recall.

There seems to be some kind of solution acording to this thread.
http://www.benzworld.org/forums/w221...nsmission.html

Problem Solved!

--------------------------------------------------------------------------------

The dealership reprogrammed the software on the 7 G-tronic once again. This time, they changed the transmission fluid and the transmission filter. Happy to report that the problem is finally solved. The car runs as new. Thanks all for your concern.

Hopefully this helps.
Try it and Please let me know how it goes.
This will not solve the problem, it will make the problem go away for a while longer and (for the Dealers) keep the car away until it is out of warranty.

This is not about W221, it is about the 722.9 Transmission fitted to many of the Benz range. Now here is the true answer:

http://www.benzworld.org/forums/w251...downshift.html

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
#7 (permalink) Old 01-27-2011, 05:44 PM
BenzWorld Elite
 
konigstiger's Avatar
 
Date registered: Jan 2007
Vehicle: '71 Pinto
Location: North Scottsdale, AZ
Posts: 2,064
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
DTB S-B-27.19/118a JUN10 – MY-All, Transmission 722.9 in Models 164, 171, 203, 204, 207, 209, 211, 212, 215, 216, 219, 220, 221, 230, 251, 463 ordering notes for Electrohydraulic Control Unit

221 – Control unit 2202701406 replaced by 2202701306 replaced by current 2202702706
konigstiger is offline  
#8 (permalink) Old 01-27-2011, 05:55 PM
BenzWorld Elite
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: S320 (W220) and Zotye 1.3/Rolls Royce on back order (LOL)
Location: Jiangsu province China
Posts: 48,370
Mentioned: 3 Post(s)
Tagged: 2 Thread(s)
Quoted: 32 Post(s)
Quote:
Originally Posted by konigstiger View Post
DTB S-B-27.19/118a JUN10 – MY-All, Transmission 722.9 in Models 164, 171, 203, 204, 207, 209, 211, 212, 215, 216, 219, 220, 221, 230, 251, 463 ordering notes for Electrohydraulic Control Unit

221 – Control unit 2202701406 replaced by 2202701306 replaced by current 2202702706
Thank you, this is what I was looking for

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is offline  
#9 (permalink) Old 01-27-2011, 07:15 PM
BenzWorld Junior Member
 
Date registered: Feb 2010
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
That is just great!!!!
I am out of warranty...

How much am I looking at?... 1-2,000 Usd ???

Its a very well know issue, So many cars are affected. why don't they just issue a recall and fix it.
Now I have to pay for their incompetence.
blssd_1 is offline  
#10 (permalink) Old 01-30-2011, 11:41 PM
BenzWorld Junior Member
 
Date registered: Jan 2010
Vehicle: S300 (W221)
Location: Malaysia
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by konigstiger View Post
DTB S-B-27.19/118a JUN10 – MY-All, Transmission 722.9 in Models 164, 171, 203, 204, 207, 209, 211, 212, 215, 216, 219, 220, 221, 230, 251, 463 ordering notes for Electrohydraulic Control Unit

221 – Control unit 2202701406 replaced by 2202701306 replaced by current 2202702706

Does this mean all models manufactured prior JUN 2010 will need this control unit replaced ? Is this bulletin apply worldwide or only in USA ?

This is bad for owners which their warranty expired.
najib is offline  
Reply

  Mercedes-Benz Forum > Mercedes-Benz Sedan Forums > W221 S-Class


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
2007 S550 Engine Problems Rick Cell W221 S-Class 22 02-03-2012 03:18 PM
2007 S550 or 2008 S550 S5504maticowner W221 S-Class 3 01-25-2011 05:18 PM
2007 S550 Duffy1 W221 S-Class 3 12-29-2009 03:41 PM
2007 S550 vs. 2007 A8L Chicagotony W221 S-Class 4 08-12-2009 11:16 AM
Why does a 2007 S550 get better gas mileage then the 2008 and 2009 S550? laxexquis W221 S-Class 2 04-26-2009 11:53 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome