Mercedes-Benz Forum banner

1 - 20 of 25 Posts

·
Registered
2002 CL55 AMG, 1993 190E 2.3L, 2004 SLK320 Sport
Joined
·
1,733 Posts
Discussion Starter #1
Check it out, my rough idle is back !
REPLACED: cap,rotor,plugs,wires,fuel filter,oil change(synthetic),both motor mounts,motor mount brackets,front bearings,complete brake job,changed all fuses,a couple of bad vacuum lines, and of course the famous OVP relay...
CLEANED: throttle body,fuel injector cleaner,idle control valve,EHA,and all throttle linkages...
MY car idles at about 600-750rpm(in drive) and 850-900rpm(in park or neutral)when the car has warmed up! And then, you guessed it, rough idle is BACK ! Rough idle is worst now in park and a little better idle in drive !
I think it's time to give up ??
I bought this car for $2490.00 a month ago ! The funny thing is that this car passed emmisions test with flying colors ???
Anybody, anything, any suggestions ??? I like this car otherwise, but it's killing me !
 

·
Registered
1987 Mercedes 300e
Joined
·
400 Posts
my brother took the car to the mechanic yesterday and they said that one of the cylinders did not have the right compression.....maybe... JUST A MAYBE because they are going to work on it today
 

·
Registered
2002 CL55 AMG, 1993 190E 2.3L, 2004 SLK320 Sport
Joined
·
1,733 Posts
Discussion Starter #4
Thanks, CHAMP
I'll wait and see what happens with your brother!
Can you keep me informed ?
thanks, Spiros
 

·
Registered
1990 W124 300TE-24 3.4 AMG, 1991 W126 300SEL
Joined
·
152 Posts
Hi

Can you check the spark plugs wires again? I knew somebody in the same garage had a similar problem and spent $$$$$$ like you too. At the end he found the fault on his brand new wires... The connector to the plugs did not sit properly.

Don't spend anymore money... time to get another w124 it would be much more cheaper.

Raf
 

·
Registered
2002 CL55 AMG, 1993 190E 2.3L, 2004 SLK320 Sport
Joined
·
1,733 Posts
Discussion Starter #6
Last night,I removed the Idle control valve.
I soaked it over night and installed it this morning!
Cleaning this valve was the solution to all my problems. My car runs MINT now! It idles at 700-750rpm in drive and 1000rpm in park! Oh, and you guessed it, "NO MORE ROUGH IDLE"...........
Changing all these parts and spending alot of money, sometimes doesn't make sense! I've learned now that you should always always start with anaylizing the cheapest problems first!!!
Thanks, for the feedback...
Spiros
 

·
Registered
1987 Mercedes 300e
Joined
·
400 Posts
hyprr1 - 4/2/2005 9:17 AM

Last night,I removed the Idle control valve.
I soaked it over night and installed it this morning!
Cleaning this valve was the solution to all my problems. My car runs MINT now! It idles at 700-750rpm in drive and 1000rpm in park! Oh, and you guessed it, "NO MORE ROUGH IDLE"...........
Changing all these parts and spending alot of money, sometimes doesn't make sense! I've learned now that you should always always start with anaylizing the cheapest problems first!!!
Thanks, for the feedback...
Spiros
can you please give me a walkthrough on how to do this? i'd like to do this just to keep it nice and clean. and on the mechanic thing my brother took the car yesterday afternoon and its still there.. i can't wait for my baby to come back [V][V][V][V]
 

·
Registered
2002 CL55 AMG, 1993 190E 2.3L, 2004 SLK320 Sport
Joined
·
1,733 Posts
Discussion Starter #9
What's up brother?
I'll try my best to explain to you on how to do this.Here we go!
-first, take off air cleaner(10mm socket wrench/remove 2 nuts and you only loosen the side one).
-remove hose going into air cleaner.
-remove air intake hose(front part of air cleaner).
-when you remove this frying pan, you'll see the valve directly in front of you.
-remove the 2 bolts(10mm)holding the bracket(Idle control valve).
-remove the electrical connection prong.
-clean electrical connection if nessesary.
-there are two hoses going into this valve(1 hose left of valve and 1 hose right).
-carefully, pry them off.
-take the bracket off the idle control valve.
-now get carb cleaner spray and soak the valve in it.
-leave it soaked over night.
-next day drain valve and you'll see alot of black and cruddy stuff come out of it.
-dry valve, the best you can and install it.
-put everything back in reverse order now.
At first, your car might have difficulty starting and it might run funny, but after taking it out for a boot, the car should run smoother!
I hope I described everything ok???
Let me know what happens, ok????
Thanks to everyone out there, that gave me great feedback!!!!!
Spiros(87' 260E, 93' 190E, 87' 190E 16valve)
 

·
Registered
2002 CL55 AMG, 1993 190E 2.3L, 2004 SLK320 Sport
Joined
·
1,733 Posts
Discussion Starter #10
A OVP(over-voltage protection relay)is a relay with a 10 amp fuse in it.The purpose of this relay is to protect your onboard computer and electronics.
go to:
http://www.thebenzbin.com/mercedes-hard-start.html
See ya, Spiros
 

·
Registered
2002 CL55 AMG, 1993 190E 2.3L, 2004 SLK320 Sport
Joined
·
1,733 Posts
Discussion Starter #12
Sorry eh, us here in Canada we call it the air-cleaner(the black oval air filter assembly)..
Thanks for that other info,
Spiros
 

·
Registered
Chevy Monte Carlo SS
Joined
·
189 Posts
Is that oil leaking on the valve cover?? If so, you need to get a new oil cap.
 

·
Registered
2002 CL55 AMG, 1993 190E 2.3L, 2004 SLK320 Sport
Joined
·
1,733 Posts
Discussion Starter #18
Oh yeah, that picture was taken about 5yrs. ago.
Since then, I've put on about 20lbs. She on the other hand, hasn't changed!
I've never been to CA. I coming to CA in Oct. for a chemist convention. Maybe I'll look you up then?
Later, Spiros
p.s. I collect Coke Stuff ! Pepsi NO GOOD!!!


the last words are "you've tested positive for COKE"
 

Attachments

·
Registered
85 300SD, 95 E320
Joined
·
341 Posts
hi Spiros .. how's the idle RPMs fix holding up? I'm wondering if I've got the same problem but my MB is fuel injected I believe.

Can I get some feedback from the forum ... when your car is in idle, do you hear the motor running or is it really quiet?
 

·
Registered
2002 CL55 AMG, 1993 190E 2.3L, 2004 SLK320 Sport
Joined
·
1,733 Posts
Discussion Starter #20
In the past 2 months, I've been so pissed off with this car! I have spent a small fortune, and still there's a little bit of rough idle! My wife thinks I'm nuts, but I know that my car is not running 100% right! I'm just about to give up and finally take it to the dealership. This way, I know what the problem is and I can repair it myself! Don't get me wrong, I know the car is 18yrs. old, but everything has been replaced and I only have 200,000km on it!
These are the things I changed or replaced:
-rear & front rotors(approx.$150) -front wheel bearings($50) -dist. cap, rotor($250) -wires, spark plugs($260) -ovp relay($100) -previous owner(alternator & battery) -motor mounts & 1 motor mount bracket($300) -cleaned throttle body -fuel filter($60) -fuel injector cleaner(every 1000km) -fixed rear window(wouldn't work)wires were cut inside door -replaced all fuses -replaced all ext. bulbs & greased all terminals plus I've done alot more misc. things. Basically, I bought this car for $2490.00 and I've put about $2000.00 into it not including the rims and stereo system.
 

Attachments

1 - 20 of 25 Posts
Top