Mercedes-Benz Forum banner

41 - 49 of 49 Posts

·
Registered
Joined
·
2,191 Posts
The changeover moment on the thermostat for me results in a short "jump" to 100*C and then an immediate drop to cool. Typically my needle sits at between 80-100*C with small movements up to what looks like 90. I'd guestimate it sits at around 86-88*C.

Turning on the heating system drops the temperature dramatically until the heater core is fully warm and then it returns back to that level.

My system could do for a nice degrease and acid flush, but I'm not in the mood to replace my waterpump if it decides to go. I did that once on my 300D and immediately had the pump start to leak. Granted it was probably on its last legs but still.

Anywho, one item that was not mentioned here as a contributor of hotter than normal running conditions: how in tune is your engine?

Before I got my car running properly, my rich running engine caused my precats to clog up causing a vicious cycle of warmer running conditions. It was always very close to 100*C.

Fixing the rich running issues and the clogged precats dropped the temp. Renewing the radiator, some hoses, thermostat, fan, and expansion tank took the temp back done even further.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #42
So.... The very first thing I want to do is say THANK YOU to EVERYONE who took the time to post here and share their knowledge and experience. THANKS!

I think my plan of attack will be as follows:

1. I ordered a timing light. I will look at the timing. I believe for the 1977, the idle should be between 700 and 750 RPM. With vacuum lines attached, I believe the timing should be set between 6 and 10 degrees at idle (with vacuum lines) and set to 27 to 30 degrees at 3000 RPM (without vacuum lines). I am not sure what to do if I get one setting dialed in but not the other, though. If these settings are not correct for this year, I ask you to please correct me.

2. The CAT is 42 years old. Take the car to a muffler shop and have them do a back pressure test. If the airflow is partially obstructed, I guess this will explain why the car can run cool until it hits 55MPH ( a higher load) - Too much back pressure forcing too much HOT air into the EGR under load. If this is the case, REPLACE the CAT. AGAIN, if this theory sounds implausible, PLEASE speak up.

3. Once it is verified that Timing and Exhaust are good, take another look at the Thermostat if it still runs hot. The car has a new one (75 C BEHR) but these came with WAHLERS. Maybe I bought a dud or the WAHLERS perform better.

4. If steps 1 through 3 don't do it, re-core the old radiator to handle a higher capacity. (I believe someone here called it having more TUBES).

If anyone disagrees with this sequence or approach, PLEASE speak up and let me know why you disagree.

Once again, THANK YOU ALL!
 

·
Registered
Joined
·
19 Posts
Discussion Starter #43
Before I got my car running properly, my rich running engine caused my precats to clog up causing a vicious cycle of warmer running conditions. It was always very close to 100*C.

Fixing the rich running issues and the clogged precats dropped the temp. Renewing the radiator, some hoses, thermostat, fan, and expansion tank took the temp back done even further.
When I bought the car, it was running VERY RICH. The smell was impossible to ignore.
I have no idea how long it had been running this way but I do know it failed emissions MISERABLY.

Goody's automotive adjusted the mixture and got the car to pass emissions. It is possible that the CAT was damaged/clogged before I took the car to them.
 

·
CH4S Admin , Outstanding Contributor
Joined
·
39,240 Posts
I don't know to what extent it applies to your R107 M117 450, but the W126 forum stickies have a link to the service manual for the W126 with engines M103, M116 (380 & 420) and M117 (500 & 560). Disc one is only diese, disc 2 all gasoline.

Edit: In Digs sticky here on top is a the R107 manual and lots of useful links.
 

·
Registered
Joined
·
2,741 Posts
I believe what he is talking about is the duality of the thermostat. When the coolant is cold, the front of the thermostat (coolant to the rad) is closed and the rear (bypass) is open to allow re-circulation of the coolant. As the coolant heats the rear of the thermostat closes and the front (coolant to the rad) opens. Unless I am mistaken, he is referring to the point at which the rear closes and the front opens, as the changeover. :thumbsup:
Indeed what I though and the very first simple check I'd make.

Someone suggested running the engine without the thermostat.
Cannot just pull it out, it will allow unfettered coolant bypass and overheat the engine.

Sorry, moving homes and little time available to post a meaningful response
 

·
Registered
Joined
·
1,324 Posts
Have you taken a good look at the radiator? My 380 still had its factory radiator. No leaks what so ever. My car was running at 100 to 110 deg C, even in late fall. It was getting scary. I inserted an inspection mirror in the lower radiator hose coupler and saw that the radiator core had a bit of mineral build up. So I opted to replace the radiator. My baby now operates at between 80 and 85 deg C where she needs to.

Take a look at the radiator.
 

·
Premium Member
Joined
·
2,339 Posts
Have you taken a good look at the radiator? My 380 still had its factory radiator. No leaks what so ever. My car was running at 100 to 110 deg C, even in late fall. It was getting scary. I inserted an inspection mirror in the lower radiator hose coupler and saw that the radiator core had a bit of mineral build up. So I opted to replace the radiator. My baby now operates at between 80 and 85 deg C where she needs to.

Take a look at the radiator.
My '83 380sl has the original rad, and I've noticed lately that it's running just under 100c (doesn't go over). Up to now it always ran between 85 and 90. When it's pushing 100, all I need do is turn on the heat and the temp drops right down to 85. Time for a new rad?
 

·
Registered
Joined
·
398 Posts
I don’t have an R107 (anymore) but I can say my 4.5 in my W108 used to run hot like you are describing. I cured a lot of it by adding a container of “water wetter” to the radiator. Made by redline I believe. It reduces surface tension of water allowing better heat transfer. Lately I cured the rest with a citric acid flush. I now run at the thermostat (I can see it open/close on the temp gage) unless I’m in standing traffic with ac. With air temps at 90 now, the car will get to 212 standing more than 10 min but drops back to 185 as soon as I drive over 30mph.
 

·
Registered
Joined
·
2,191 Posts
When I bought the car, it was running VERY RICH. The smell was impossible to ignore.
I have no idea how long it had been running this way but I do know it failed emissions MISERABLY.

Goody's automotive adjusted the mixture and got the car to pass emissions. It is possible that the CAT was damaged/clogged before I took the car to them.
How long ago was this?

"Adjusting the mixture" to pass emissions sounds like you have some underlying issues. False air, improperly configured injection systems, and of course a partially clogged cat might be leading to the warmer than average running temperatures.

Personally, I would stop taking your vehicle to Goody's and begin on the adventure in diagnosing this yourself.

Now, I'm not sure if your car is a DJET or KJet engine so others will have to chime in. But your vehicle needs a proper dressing down to see where it stands.
 
41 - 49 of 49 Posts
Top