Mercedes-Benz Forum banner

1 - 10 of 10 Posts

·
Registered
w163 ml
Joined
·
208 Posts
Discussion Starter #1
I recently bought bi-xenon headlights of ebay i bought each unit seperate from individual sellers.
They both came throught at the same time in perfect condition.
I have read on previous posts that if the car does not get version coded ie from halogen to xenon i will see a faint flicker.
I installed them today switched them on and they both came on GREAT i thought, may be not.
I started the engine and the drivers side flickered really bad and the passenger side went out completely.
Switched of engine switched lights off then on and came on Great.
Anybody have a clue.
My car is a 270 CDI 2002 and iam from the uk.
The reason why i installed today was i had my truck in to have 2 rear headrest screens installed with DVD player, the job went worse i came to collect my truck and the guy installing the screens had blown both new screens incorrect polarity i really had a bad day today.
Could it get worse ( Or Should I Say That )
As a side note my truck was in at the dealers to check out a small oil leak from the turbo and i asked would it be possible to version code my xenons and the tech guy said its impossible to install bi-xenons afterwards on the truck.
I know and all you guys know its possible, there possibly protecting there backs as they do.

Thanks in advance.

PS : Would it be possible to get round the version coding by picking another source of 12v ie cigar lighter and control these lights through a relay i bet it would work any comments.

The xenons are from germany
 

·
Registered
'02ML320
Joined
·
806 Posts
for 02+ models, you have to reprogram the computer to recognize xenon lights, but i believe somebody here wired the lights to auxillary lights and worked fine
 

·
Registered
2001 ML 55AMG
Joined
·
1,158 Posts
You need to upgrade the headlight fuse to a 20amp. Although the Bi-xenons use less overall power there is an initial spike in the power and the fuse used for the regular lights can't handle it.
 

·
Member
'00 ML320 Elegance
Joined
·
8,965 Posts
Benza - 5/10/2005 6:43 PM

You need to upgrade the headlight fuse to a 20amp. Although the Bi-xenons use less overall power there is an initial spike in the power and the fuse used for the regular lights can't handle it.
Actually it's okay for '00+ MLs, and the fuse upgrade is unnecessary. It is only required for '98 and '99 MLs. [:)]

The flickering is caused by the AAM not recognising that Bi-Xenons are present.
 

·
Registered
Joined
·
54 Posts
WOZ did you need to do any additional wiring to fit the Xenons?? And how you reprogram the AAM, can you do this by the diagnostics plug in the car???
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550, 2011 C300 FORMER: ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
19,231 Posts
WOZ did you need to do any additional wiring to fit the Xenons?? And how you reprogram the AAM, can you do this by the diagnostics plug in the car???
For MY2002-2005, the bi-xenon headlight assemblies use the same plug as the halogens. Also, the AAM must be programmed for the xenon lights to function properly. I’m not sure why this is, but this programming can only be performed by a technician with the Star Diagnostics system – it is not user-programmable (well, unless you are a user that spent the $10K to buy a Star Diagnostic system).

If you have a pre-MY2002, you will need either a pigtail adapter to connect the assemblies, or you will need to buy the bi-xenon lights from a reseller that modifies the assembly to use the older plug style. There is no re-programming necessary on these models.
 

·
Registered
Joined
·
6 Posts
you need to run a separate relay for each light in order for them to stop flickering, as for any car. no need to reprogram. i did that to my 03 ml. i try without relay at first and it does flicker. with relays, i 've been using it ever since with no problem.
 

·
Registered
02 ML320
Joined
·
191 Posts
I have a 02 320 and I installed after market hids straight to the halogen power wire.It flickers for about 5 secs when started but then stops.Does yours flicker all the time?
 

·
Registered
w163 ml
Joined
·
208 Posts
Discussion Starter #9
yes a constant flicker i took them out and put my halogens back in.
They looked great as well.
 

·
Registered
'02ML320
Joined
·
806 Posts
thats just rubbish! perhaps you can try another dealer?

woz - 5/10/2005 7:06 PM
i asked would it be possible to version code my xenons and the tech guy said its impossible to install bi-xenons afterwards on the truck.
 
1 - 10 of 10 Posts
Top