Mercedes-Benz Forum banner

1 - 10 of 10 Posts

·
Registered
'01 ML55
Joined
·
972 Posts
Discussion Starter #1
I thought that the bulb was tost, so I bought a new bulb, still does not work, also checked the fuse, it's fiine. any ideas as to what the problem might be?
 

·
Premium Member
02 ML320 06 ML500
Joined
·
17,104 Posts
Baring any broken wires,which I doubt, I'm almost sure it is going to be the combination switch.
 

·
Registered
'01 ML55
Joined
·
972 Posts
Discussion Starter #3
Baring any broken wires,which I doubt, I'm almost sure it is going to be the combination switch.
Thanks for the reply! I gather that when you say "combination swithch" you are refering to the black control unit that twists on to the back of the bulb?
 

·
Premium Member
02 ML320 06 ML500
Joined
·
17,104 Posts
The combination switch is under the steering wheel. The item with the stalks on either side; it controls the signals, headlights, emerg. flashers and wipers.
 

Attachments

·
Registered
'01 ML55
Joined
·
972 Posts
Discussion Starter #5
The combination switch is under the steering wheel. The item with the stalks on either side; it controls the signals, headlights, emerg. flashers and wipers.
Thanks again for the reply. Do you think that would cause only the one Xenon bulb not to work? the turn signals and both high beams function.
 

·
Registered
Black 2005 ML 500
Joined
·
1,662 Posts
Xenon problem HELP

Connect the bad headlamp to the other side and see if it works. Check, too all the connections.. You can compare the wiring connections to the other headlamp.

AC
 

·
Registered
'03 ML350
Joined
·
211 Posts
You can try swapping the igniter(the one attach to the lamp itself) and see what happens. You maybe able to buy used Hella igniter and/or ballast from ebay for relatively cheap.
 

·
Registered
'01 ML55
Joined
·
972 Posts
Discussion Starter #8
You can try swapping the igniter(the one attach to the lamp itself) and see what happens. You maybe able to buy used Hella igniter and/or ballast from ebay for relatively cheap.
It was the igniter, replaced it and all is good! Thanks for the advice!
 

·
Registered
Joined
·
1 Posts
hi there i have a same problem on my w208 clk230 2000reg any idea where can i buy the right igniter? a was searching over a week on the internet and nothing :( can u send me on the [email protected] plz many thanks
 
1 - 10 of 10 Posts
Top