Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
275 Posts
Discussion Starter #1 (Edited)
Hi all,

2000 E320, 60K. on it. Tonight, on the way home, I noticed that the color of the two headlights are different. As I have factory Xenon HID installed the passenger side is slightly blue, as it has always been, however the driver side is just regular color now.
The lamp malfunction indicator on the instrument cluster is not on as the light still works but it has lost the blue hue. I did search but couldn't find anything related to this kind of issue.

Any help would be appreciated.

Alex
 

·
Registered
Joined
·
632 Posts
Haven't had any trouble with mine but awhile back someone pointed out they change color before failing. Happens with other lighting so I guess it makes some sense. Can't confirm.

BTW, the reason for asking for your location is that it can help diagnose problems (weather) or someone might know of a good mechanic nearby, etc. Or you might make a friend out here who lives by.:)
 

·
Registered
Joined
·
239 Posts
Usually tehy don't dim before they go out. They usually just go out. If it is dimming , it probaly means that it is not getting enough"spark" from the ignitor. When you buy a new bulb , they do take time to adjust and become the same blue as the one you already have. But that should only take a day or so.
Shawn
Mercedes-Benz of Annapolis
www.getmercedesparts.com
 

·
Registered
Joined
·
275 Posts
Discussion Starter #4
Thanks guys.
Actually it looks like I made mistake and the driver side is the good light with the correct color and the passenger side is the one that changed color and it is deep blue now.
I took the bulb out and when I shake it is sounds like the filament inside is broken. I put it back in and it has intermittent contact so it is time for a new bulb.
I ordered it already from Autohausaz for $85.20.

Alex
 
1 - 4 of 4 Posts
Top