Mercedes-Benz Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Guys,

I had an accedent, and the base (the place where we mount it to the car body with a skrow or somthing) of my 98 E240 Xenon headlight is broken.

I went to several workshop and they told me that you have to bye a new headlights since they dont have the base alone!!!

is it true that i cannot benefet from my working light (the lens and the glass are OK)

and changing them will cost me > 1450 USD!!!!

what the hell, they are working fine but i cannot mount them to the car!!!

anyone could help please.....
 

·
W203, W210 Moderator
E55 ///AMG
Joined
·
6,911 Posts
Sorry to hear that, can you post a pix so we can see what's going on? Btw, Welcome to the Board!

JOE55
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Sorry for being late, but the workshop tried to fix the light and they end up with a solution that i cannot judge untie i drive the car

it will finish two days from now :)

you can check the attachment for the pics
 

Attachments

·
W203, W210 Moderator
E55 ///AMG
Joined
·
6,911 Posts
gt2000sa said:
Sorry for being late, but the workshop tried to fix the light and they end up with a solution that i cannot judge untie i drive the car

it will finish two days from now :)

you can check the attachment for the pics
Good luck & keep us posted,
JOE55
 

·
Registered
'07 GL320CDI
Joined
·
5,116 Posts
gt2000sa said:
what the hell, they are working fine but i cannot mount them to the car!!!
If that's what you have to do to fix it, that's what your insurance will pay for.
 
1 - 6 of 6 Posts
Top