Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
'83 300CD
Joined
·
53 Posts
Discussion Starter #1
OK, it's been awhile but this one has me stumped.

My heater is blowing fuses. Some times it takes 2-3 weeks, today it blew in 25 minutes. Today I noticed the smell of burning electronics and my cabin filled up with smoke.

I am at a loss where to even start, this is all I've done so far...

  • Swapped heater w/ parts car... the old one works fine in my old 240
  • pulled out my switch box that controls defrost/vents/Hi-Low blower and nothing seems to show anything would lead me to believe it was the source of the smoke
  • Checked around my CD player thinking maybe the mounting frame was cutting into a wire and found nothing.

My alternator also went on me last week but i'm going to chalk that one up to my 27 mile - 7 1/2 hour commute last wednesday. Anything around the DC metro area was a parking lot.


:surrender:

Suggestions as to where I should even start?
Anyone experienced anything like this before?


The car is a '83 300CD w/ 197K... it was like a cat on carpet in 10" of snow last week :D
 

·
Registered
1984 300D
Joined
·
5,065 Posts
I can only repeat some things I have read.

When the Blower Motor gets old it starts pulling more amps and blows Fuses. There is a kit with a higher amp fuse that goes on the wire down by the Blower.

However, some have said the actual cause is the Motor dragging on the Bearings due to old dried up lubrication and worn Brushes.

Also on my 84 300D on the Right inner Fender Well is a square sheet metal box with a bunch of resistance coils inside. Those coils have to do with the Blower Motor Speed Control. I am not sure but part of the current is supposed to pass through the Coil. But, that cannot happen if the connections to that Coil are corroded.
Also I have seen that Coil full of crap from the Road that would insulate it.

On mine also on that Right Fender Well is a little electric Auxiliary Water Pump. If that seizes up and shorts out it fries part of the Climatic Control inside if the Car and in 3 years of reading on the forums has cause 2 car interior fires.

If you go to the peachparts diy section there is a thread on installing a Fuse on the Aux Water Pump (it does not have one from the Factory). I believe it was a 3 amp Fuse but am not sure.
 

·
Registered
1985 380SE
Joined
·
1,939 Posts
Also on my 84 300D on the Right inner Fender Well is a square sheet metal box with a bunch of resistance coils inside.
Do you have a picture of that box? I'm curious if the 240 is equipped with the same thing, although it could be different because the 300 has automatic climate control while the 240 has manual climate control.
 

·
Premium Member
Joined
·
496 Posts
I would replace the brushes in the blower motor. Even if it DID work in the old 240, jossling it around may have loosened some gunk and it's now taking more amperage to spin. I had to replace the brushes in my 300CD because of these same symptoms. I replaced them, and gave it a good once over with an electronic parts cleaner spray. Use the cleaner at your own risk, some say it's not good for the lubricant, but the amount of black dust & gunk from the years of service looked like it'd be better off after having been sprayed.

Dave aka Ghan
 

·
Registered
'83 300CD
Joined
·
53 Posts
Discussion Starter #6
Yeah, I think that's a little more than the two 5lb fire extinguishers that ride around with me could handle.

If I'm reading what 300Dman(Thanks BTW) sent me correctly Fuse 8 feeds:
  • Compressor Relay
  • Electronic Unit for blower speed control
  • Push button Control assembly
Does anyone know any way to trouble shoot the Electronic unit for blower speed control?

The blower motor relay appears to be clean, clear, and good working condition.

I plan on checking and getting a fuse on the aux pump tomorrow after work. As I recall from previous heater issues i should be able to just connect 12v to it and if it's working i should hear water flowing.

I'll be checking out the CCU tonight and check back in.
 

·
Registered
'83 300CD
Joined
·
53 Posts
Discussion Starter #8
240 Benz.... this is the 300CD, for some reason I dont think the 240 has one but I could be mistaken.

 
1 - 8 of 8 Posts
Top