Mercedes-Benz Forum banner

1 - 14 of 14 Posts

·
Registered
2005 Mercedes Benz CLK500
Joined
·
30 Posts
Discussion Starter #1
So i recently ran into a prob to begin with my car drives great goes into gears smooth now recently i ran into a prob where if i back up from my parking spot and then try to just pull back in it wont shift into park or reverse.. so i have to put in into neutral push it out drive a lap come back in and then it parks.. done this to me like 5 times already.. another thing ramdomly driving my abs and my brake error light turns on but it goes away after i turn off the car and i noticed it does that after rain but i can be wrong maybe just a coincidence.. whats happening??? Any clues ideas??

Sent from AutoGuide.com Free App
 

·
Registered
W208 320 Cab
Joined
·
38 Posts
Not sure and a bit of a guess if you haven't already have you changed the brake pedal switch, maybe the car doesn't think the foot brake is on, they fail anyway (normally they strand you in park!) plus really cheap from the dealer, mines on its 3rd one, they wear out,


Sent from AutoGuide.com App
 

·
Registered
2005 Mercedes Benz CLK500
Joined
·
30 Posts
Discussion Starter #3
No it breakes good it like once i reverse stop put it in drive pull back to the spot it just dosnt let me put it into reverse or park it just lets me shift between neutral and drive.. so i have to push my car back drive around for not even a minute and then it goes into park no problem.. and the abs brake error turn on randomley while driving i have to stop turn off the car and it goes away i read it somewhere before thats its some sensor.

Sent from AutoGuide.com Free App
 

·
Registered
2008 E320 Bluetec, 1988 560SL totalled unto death). 1997 Dodge Ram 1500, 1983 300CD
Joined
·
1,331 Posts
Had identical issue

with my W123. Granted a much older car but the problem and solution would be worthy of your consideration. I assume your shifter bushings are in good shape as mine were.

In my case, the shifter shaft was a tiny bit loose and twisted very slightly to misalign and prevent engagement in the desired slot UNDER the console. Try this; next time it happens put a small amount of torque on the shifter, one way or the other, then see if it slips into the desired slot. If it does, simply remove the console face, align the shaft and tighten down.

Please come back to let us know if this works.
 

·
Premium Member
2004 CLK 240 Coupe
Joined
·
11,377 Posts
No it breakes good
You have been offered advice above - and ignored it.....

You were not asked if the brakes worked. You were asked if you had changed the brake light switch located under the pedal, as this is a known cause of your problem. Try that, and report back.
 

·
Registered
2005 Mercedes Benz CLK500
Joined
·
30 Posts
Discussion Starter #6
You have been offered advice above - and ignored it.....

You were not asked if the brakes worked. You were asked if you had changed the brake light switch located under the pedal, as this is a known cause of your problem. Try that, and report back.
Dont take it personal i take all tje advice i can get i already put close to 4k ir repairs so trust me everything u guys suggest ill take it in.. and no i have not changed the brake light switch.. but with that wouldn't it leave me stranded in one gear?? Now it lets me go to neutral and drive it just wont go into reverse or park till i push it out take a spin around the parking lot.. also idk if it makes a dif the parking spot is on a tiny incline but i mean TINY.
 

·
Premium Member
2004 CLK 240 Coupe
Joined
·
11,377 Posts
Dont take it personal...

... also idk if it makes a dif the parking spot is on a tiny incline but i mean TINY.
I take nothing personally here...:)

You may not know, but your W208's shift selector can generate something called R/P lock, which is designed to protect the transmission. This might be causing your problem. The operation is explained in the WIS drawing below.

It could be mechanical wear on the moving parts, and you may note that the brake pedal switch is involved here.

I don't think that the incline affects anything.
 

Attachments

·
Registered
2005 Mercedes Benz CLK500
Joined
·
30 Posts
Discussion Starter #8
I take nothing personally here...:)

You may not know, but your W208's shift selector can generate something called R/P lock, which is designed to protect the transmission. This might be causing your problem. The operation is explained in the WIS drawing below.

It could be mechanical wear on the moving parts, and you may note that the brake pedal switch is involved here.

I don't think that the incline affects anything.
Wow thanks. Ill try to check it out this weekend ill keep you guys updated.. its just weird thats it only happens after reversing. As for the break error lights any clue?? Can it be just the dust on the sensor or something small?? It gives me 3 errors abs bas esp.

Sent from AutoGuide.com Free App
 

·
Registered
W208 320 Cab
Joined
·
38 Posts
With the brake light switch when mine failed I took it apart, I don't really understand how it works but I scraped the contacts and got it going again till I could get a new one, they are so cheap from the dealer even if it makes no difference it's a spare, and it will fail at some point anyway : - )


Sent from AutoGuide.com App
 

·
Registered
2002 c240
Joined
·
1 Posts
2002 c240
I replaced the radio. disassembled the center console, installed radio and reassembled the console. everything went perfect without any problems. The very next stop I made was at a gas station. I pulled into a parking spot and tried to put the car in park, but it would not go above neutral. I put it in neutral and applied the parking break. I was not able to take the keys out of the car, as they can not be removed without the car being a park. when I tried to put the car in reverse to leave I discovered that I couldn't do that either. I had to put the car in neutral and push the car out of the parking spot in order to leave the gas station. The car is functioning perfectly in every way, except I cannot get the shifter to engage in reverse or park, it will only go into neutral and drive.

I have been told that it is likely a very simple fix replacing a clasp on the linkage of the shifter? I put it up on a lift and looked at the connection and nothing seems to be missing, but i dont really know what i am looking for. there is some play in the rod connecting the shifter to the transmission, but the assembly on both ends seem to be in order. can anyone shed some light on what my problem might be?

I have read something about an issue with the break pedal sensor, but the break lights come on when i apply the breaks.

Is this issue known to anyone out there? If so can you offer detailed instructions on how to repair it? Pictures would be great. Thank you.
 

·
Registered
CLK 320 2001
Joined
·
118 Posts
Rocky, your torque suggestion worked for me. So, how exactly do you fix this issue. I know you state to remove the center console. How exactly do I I remove it and then make the repair


Thanks!
 

·
Registered
Joined
·
598 Posts
Read through this thread from the archives.

https://www.benzworld.org/forums/w210-e-class/1261790-abs-light-came.html

Member A1EK describes exactly how to change the switch, and includes a photo. It is on a W210, but your W208 will be similar. It might not solve your R/P problem, but it is a useful start.

Go to the dealer....buy a $15 new brake light switch (not Ebay)....the ABS error and inablility of car to allow shifting all sound like the known CLK brake light switch problem...has been discussed so many times...search this and other MB forum
 

·
Registered
CLK 320 2001
Joined
·
118 Posts
But I got my car to shift by twisting the gear shift left or right prior to shifting back into park and it worked. That still means it’s my brake switch?
 
1 - 14 of 14 Posts
Top