Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello all, I bought my first car yesterday it is a 1989 190e 2.6 it has 200k miles on it, everthing good on it besides it wont pass smog, the smog guy say it is over heating at 50 mph, it is unsafe to drive and the enigne is loud. He told me to take it back monday and try it again my question is there anything major wrong with it or anything i can do to pass it. There is no white smoke coming out when i start the car.Any help will be much appreciated.

Here some more infromation about the car. The smog place was 2 blocks away and i did not warm the car up. Also when i bought it the guy said i got to have the fan inside on or it over heat and older mercedes need that on.
 

·
Registered
89 190E 2.6 x2, 99 SL500 Sport
Joined
·
1,797 Posts
First of all is this a California Test Only smog check you're talking about?
The best advice I can give, is make sure you give your car a good spirited run on the freeway before you bring it in. The purpose is to heat up the cat as hot as possible, so it's most effective. The m103 engines (2.6) are not very friendly to the newer stricter California smog laws. Mine barely passes the Test Only station every other year.
 

·
Registered
2.3-16v Evolution2 Replica
Joined
·
493 Posts
While heating your cat is good for passing the 25MPH load test it wont help you on Idle test. My car failed California test for high NOX on Idle but the running load was fine.

If your car is said to be over heating you need to get it looked at ASAP. This will save you money and problems in the long run trust me.
 

·
Registered
SLR
Joined
·
1,366 Posts
If your car is said to be over heating you need to get it looked at ASAP. This will save you money and problems in the long run trust me.
Yes, immediately is an understatement. I got slammed with a $4000+ bill when that happened.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #7 · (Edited)
Thank you all for the advice again. and I went today and the guy say there a pressure problem and a leak where the water reservoir and or another part(i dont know to much about cars) he said he going to cheap route and going replace both of them. and if its not that he say its a blown head gasket that be causing it. and i bought it in denair about 2 hours away from sarcramento.
 
1 - 7 of 7 Posts
Top