Mercedes-Benz Forum banner
1 - 5 of 5 Posts

·
Registered
1973 450SL
Joined
·
169 Posts
Discussion Starter · #1 ·
After four years of body, paint, mechanicals, interior, etc, my SL is about finished. Yay. Much thanks to the folks here who have helped by offering advice, and by not ridiculing my amateurish attempts.

Just a few things to wrap up, but it drives well, and I'm in no big rush to get the last few things done. Except... The lighting system is misbehaving. Headlights & taillights turn on and off as normal. The brake lights work. But the turn signals are inop. When I put the car in gear, the right turn signal light on the dash lights up solid, and stays on. The exterior turn signals do not light up at all. When I signal "left", the inside light flashes very quickly, but no outside signal. Signal "right", nothing happens.

Flasher is the only thing that comes to mind. Any other bright ideas?

Ed

2705183
 

·
Premium Member
1983 380SL, 2000 S430, 1991 420SEL (retired) - RHD
Joined
·
6,330 Posts
Sounds like Murphy is back and hiding in your electrics :eek: Maybe first check all your fuses. The best ones are copper. Also an extra earth connection or two is a good idea .
 

·
Premium Member
1988 560SL, TRQ
Joined
·
305 Posts
After four years of body, paint, mechanicals, interior, etc, my SL is about finished. Yay. Much thanks to the folks here who have helped by offering advice, and by not ridiculing my amateurish attempts.

Just a few things to wrap up, but it drives well, and I'm in no big rush to get the last few things done. Except... The lighting system is misbehaving. Headlights & taillights turn on and off as normal. The brake lights work. But the turn signals are inop. When I put the car in gear, the right turn signal light on the dash lights up solid, and stays on. The exterior turn signals do not light up at all. When I signal "left", the inside light flashes very quickly, but no outside signal. Signal "right", nothing happens.

Flasher is the only thing that comes to mind. Any other bright ideas?

Ed

View attachment 2705183
I had a similar issue and it was the flasher.
 

·
Premium Member
1980 450 SL
Joined
·
418 Posts
After four years of body, paint, mechanicals, interior, etc, my SL is about finished. Yay. Much thanks to the folks here who have helped by offering advice, and by not ridiculing my amateurish attempts.

Just a few things to wrap up, but it drives well, and I'm in no big rush to get the last few things done. Except... The lighting system is misbehaving. Headlights & taillights turn on and off as normal. The brake lights work. But the turn signals are inop. When I put the car in gear, the right turn signal light on the dash lights up solid, and stays on. The exterior turn signals do not light up at all. When I signal "left", the inside light flashes very quickly, but no outside signal. Signal "right", nothing happens.

Flasher is the only thing that comes to mind. Any other bright ideas?

Ed

View attachment 2705183
I like your MG TD. When I was a teenager working in my Dad's service station when one of these came in I was full of envy and thought some day I will drive one of these and the girls will all want to be seen in it with me. LOL I never did get one but always liked the way the look. I found out the maintenance and issues with English built cars in those years were a problem so I didn't purse this dream when I got older.
 

·
Registered
1973 450SL
Joined
·
169 Posts
Discussion Starter · #5 ·
I like your MG TD.

Thanks. I learned to drive in THAT car. My wife & I restored it back in 1992-93. It's got a few scratches & a couple little dents now, but it still runs great. Quite reliable and easy to work on. And fun to drive...

2705291
 
1 - 5 of 5 Posts
Top