Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I am looking for wiring diagram or lighting information for an 02 g wagon. rh park lamp circuit front and rear is not working. Need help or info please (diagrams/common problems etc would be great). No experience working with these vehicles. Thanks!
 

·
Registered
04 Adventurewagen
Joined
·
616 Posts
I am looking for wiring diagram or lighting information for an 02 g wagon. rh park lamp circuit front and rear is not working. Need help or info please (diagrams/common problems etc would be great). No experience working with these vehicles. Thanks!
All your lighting circuitry is controlled by an ECU - electronic control unit - onboard computer.
As soon this computer detects a fault in one of the circuits, it will shut down the power for that particular circuit. When you recycle the ignition the affected circuit will come hot again - just for a moment before the computer shuts it down again and displays an error message.

Just install new lamps, check the wiring at the lights for nicks or cuts and turn on that circuitry - the lights should come on again.

A very nice feature (might have to be enabled with the Star System) when the rear tail light lamps burn out, the brake light bulb next to it will start to glow as a replacement automatically.

Any wiring diagram (current flow chart) for your vehicle is very complex and not easily read.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
replaced bulbs for taillamp, park lamp inside headlamp and lisc plate lamps. still no luck. no park lamps in any headlamp switch position, no fog lamps. truck was at a body shop, looking for ground/power wire locations/ecu/headlamp switch pinout. is each side fused separately, wiring cut somewhere, etc. the brake lamp is not coming on and there is no power coming on for even a second when lights are switched. I am wondering if the grounds for the lighting ckt are within the ecu or at a ground point somewhere on the vehicle that possibly the body shop left off?
 

·
Registered
04 Adventurewagen
Joined
·
616 Posts
replaced bulbs for taillamp, park lamp inside headlamp and lisc plate lamps. still no luck. no park lamps in any headlamp switch position, no fog lamps. truck was at a body shop, looking for ground/power wire locations/ecu/headlamp switch pinout. is each side fused separately, wiring cut somewhere, etc. the brake lamp is not coming on and there is no power coming on for even a second when lights are switched. I am wondering if the grounds for the lighting ckt are within the ecu or at a ground point somewhere on the vehicle that possibly the body shop left off?
That really sounds serious. There are no fuses for the lighting - everything is controlled by the ECU.

If the lights all worked before the work at the bodyshop, have them deal with it - getting it to the MB dealer to check the system with the Star Diagnose system.

Please keep us updated.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
found issues, more bulbs all over, wiring under rear bumper, fuse blown in fuse block rh side of dash that must have been part of lh lighting. truck is a 300g waggon imported here I guess... thanks a bunch for the help. one of the fog lamps is trashed, rusted badly, not able to get a good ground for the h3 bulb through the base of the bulb, where to get this lamp housing??
 

·
Registered
-86 W460 300 GD, Previous; -04 G400 CDI
Joined
·
9 Posts
on my 04 g400 left rear tail light and left rear interior light is not working, i have to replace the sam/ecu. might be the same case with yours? mine is located under the center console.
 
1 - 7 of 7 Posts
Top