Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
1984 Mercedes 300SD
Joined
·
176 Posts
Discussion Starter #1
Hi,
I own a 300SD and today actually i spend hours trying to fix my rear left speaker.... its been like that when I got it, i recentley got it 7 month ago as a gift from a friend, first car. While trying to fix it i found a Harness which i have no idea what needs to go in the other side, also i found out that the speaker wire is all the way connected to my Cassette Player for some reason it just doesnt work and its 4 Brand New Speakers.

Heres Images if they dont work ill put a link below







Heres link incase they dont work


http://www.geocities.com/extreez/carunkown/IMG_0010.JPG
http://www.geocities.com/extreez/carunkown/IMG_0011.JPG
 

·
Registered
1991 300 SE
Joined
·
18,534 Posts
I don’t recognize the wiring –
I could be wrong but they look
after market as if there was a
changer or speaker setup in
the trunk.
 

·
Registered
Depends on the day!
Joined
·
13,337 Posts
I wouldn't bother with what ever that is.. I'd recomend running all new speaker wire..the stock wiring is Awfully thin.

Jonathan
 

·
Registered
93 190E 2.6; 82 300 SD Turbo
Joined
·
1,678 Posts
The connector on the right side of the photo is for a speaker, I have the same thing in mine, Circuit City installed speakers and they must have used those, as for the unknown connector i would suspect maybe something for a CD Changer or other add-on, possibly (but probably not) Maybe HI-LEVEL inputs for an subwoofer amp or other such thing....but as Jonathan mentioned i wouldnt bother with it, plug that one wire into your speaker---if it is muting everything else check the wiring at the back of your head unit, something could be amis or the wire itself shot...


Hope this helps,

Kris
 
1 - 5 of 5 Posts
Top