Mercedes-Benz Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Been searching the forums but can't seem to solve my problem. I have a 2002 C320 Wagon and the wipers won't turn off. Intermediate, normal and fast settings work normally, but back in the off position the wipers continue to operate as if in normal continuous mode. Wiper fuse is ok. Swapped the relays around and problem persists. Took the relay apart and cleaned it as some forums suggest. Then bought a new wiper switch and installed and no change. I thought about the rain sensor although I don't think that should cause this. Fuse fine. Problem the same whether the sensor connector is disconnected or connected. It was suggested that the park position sensor in the wiper motor was bad but I swapped the wiper motor and the problem remains. In the intermittent setting the wipers stop in the proper position between swipes. The wipers were off initially after I changed the motor but once I pressed the switch to spray the windshield with washer fluid the wipers came on and won't turn off even in off position. I would appreciate anyone's expertise. Thanks.
 

·
Registered
Joined
·
2,224 Posts
This W203 wiper mechanism is good but how much I hate electronic ,rain sensors part of it ..but the engineers may come to the rescue some time like my condition : Turn wiper on : not working regardless rain or shine with engine running at any stop but will activate wiper soon as I let go brake pedal and hit the gas to accelerate and repeat this cycle again and again ...WTF ..Oregon is famous rain and rain is consistent like this month that make me blind when at traffic red light or some one behind me give me a horn sound...very scary most of time ..Love to know why ?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I have a couple of additional symptoms to add to the story of my wipers not turning off. First of all I noticed that when the door is open the wipers stop. Then with the door closed they start back again, even though the switch is in the Off position. Next, while I was driving today with the wipers running in the intermittent mode, the headlights, set to the "auto" setting were switching off and on, maybe every 3-5 seconds. This was not occurring if I turned the wipers to the slow, fast or off positions. I'd love to hear your ideas. Thanks.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Thanks, Rodney. That was one of my initial thoughts, but I swapped the relays that look identical, L and Q on the diagram and it did not have any effect on the problem. I also popped the cover off the relay and sprayed some contact cleaner in it. I had to have the whole front SAM replaced last year after the battery died and had to be replaced. Any other thoughts? Shouldn't swapping the relays have shown if it was a relay problem? Any other thoughts. Thanks.
 

·
Coupe/Convertible Forums Moderator
Joined
·
18,686 Posts
If you remove the relay do the wipers stop? If not, it's wiring problem. If so, then I;d suspect the SAM.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
I removed the relay and the wipers stop. I've been hopeful it wasn't the SAM but was worried it might be. I do have the factory manual and the replacement of the SAM unit appears straightforward. However, the instructions say to connect STAR DIAGNOSIS and buffer basic data and then reload after the swap. Can the swap be done without this step? I'd like to do this myself if possible. What happens if I skip that? Thanks. Also, I'd appreciate any other opinions on the subject before purchasing this part.
 

·
Coupe/Convertible Forums Moderator
Joined
·
18,686 Posts
If you get a new SAM, it must be coded using SDS. If you were to get a SAM from a car exactly like yours - same year and options, then it should be plug and play.
 

·
Registered
Joined
·
2,224 Posts
If you get a new SAM, it must be coded using SDS. If you were to get a SAM from a car exactly like yours - same year and options, then it should be plug and play.
Hey Rudeny ,,so any mechanical parts if content software from donor car ( of course same car ) should be able to swap without coding :confused: most parts ?
 

·
Coupe/Convertible Forums Moderator
Joined
·
18,686 Posts
Not all electronics can be swapped. Some require SCN coding, like the instrument cluster, ignition switch, 722.9 TCU, etc. But the coding on a SAM is just for it's enabled options, so generally, it can be swapped as long as it comes from an identical donor car.
 

·
Registered
Joined
·
2 Posts
Same problem

Hello, My C180 has exactly the same problems as you describe. - The only way for me to turn the wipers off is when the wipers reach the rest position you have to turn off the ignition key whilst driving, take the key out, put it back in and start the engine again (all whilst driving along the road). Then the wipers stay in the off position.

So did you ever discover the reason and rectify the problem ? Did changing the SAM unit work ? was it the front or the rear SAM unit ?

Thanks
Harry
 

·
Registered
Joined
·
2 Posts
wipers won't turn off

Hello

I have exactly the same problem with my wipers, they won't turn off.

Did you ever remedy the problem and what was the solution ?

Thanks
Harry
 

·
Registered
Joined
·
252 Posts
Hi Harry

I don't have the problem, but a common issue is a wire (in your case, connected to the Wipers) which has worn through and copper is coming in contact with the body (ie earthing) causing a bridge and keeping a circuit open.

Find an Auto Sparky with intimate knowledge of the wiring or you can trace it yourself through a "trial and error" approach.

Hutcho
 

·
Registered
Joined
·
2 Posts
I have a couple of additional symptoms to add to the story of my wipers not turning off. First of all I noticed that when the door is open the wipers stop. Then with the door closed they start back again, even though the switch is in the Off position. Next, while I was driving today with the wipers running in the intermittent mode, the headlights, set to the "auto" setting were switching off and on, maybe every 3-5 seconds. This was not occurring if I turned the wipers to the slow, fast or off positions. I'd love to hear your ideas. Thanks.
 
1 - 15 of 15 Posts
About this Discussion
14 Replies
6 Participants
david48
Mercedes-Benz Forum
BenzWorld.org forum is one of the largest Mercedes-Benz owner websites offering the most comprehensive collection of Mercedes-Benz information anywhere in the world. The site includes MB Forums, News, Galleries, Publications, Classifieds, Events and much more!
Full Forum Listing
Top