Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Premium Member
1996 S320 (Kuro) 1998 S600 (Weiss)
Joined
·
2,886 Posts
Discussion Starter #1 (Edited)
Hi guys,

99' W202 with the above issues. I've searched and found that there seems to be a common fault with the relay and also the indicatar combination indicator/wiper arm on the steering column however the indicators work fine so it (I believe) rules out the relay.

This began happening after heavy rain and now the radiator fan doesn't kick in at all (the car will just overheat) and the wiper finally stopped working completely (however it does make a noise).

Any ideas on what order it would be best to start replacing parts in?

Thanks in advance :bowdown:
 

·
Premium Member
1996 S320 (Kuro) 1998 S600 (Weiss)
Joined
·
2,886 Posts
Discussion Starter #2
Bump - c'mon guys - any help here?
 

·
Registered
2013 VW Golf Sportwagen TDI, 2011 Mazda 2, 2000 E320 4Matic Wagon (retired),1994 C280 (retired)
Joined
·
3,488 Posts
I don't know for certain, but the first thing I'd be checking were all the fuses. Both the high speed and low speed fan relays have fuses in them.

Try turning on your air conditioning. The low speed fans are supposed to come on when your car is at operating temperature and the air conditioning is engaged. If your fans come on when your a/c turns on, then you know the fans work. You then need to find out why they don't work without the a/c.
 

·
Premium Member
1996 S320 (Kuro) 1998 S600 (Weiss)
Joined
·
2,886 Posts
Discussion Starter #4
I don't know for certain, but the first thing I'd be checking were all the fuses. Both the high speed and low speed fan relays have fuses in them.

Try turning on your air conditioning. The low speed fans are supposed to come on when your car is at operating temperature and the air conditioning is engaged. If your fans come on when your a/c turns on, then you know the fans work. You then need to find out why they don't work without the a/c.

Thanks for the reply!

Fuses and relays are ok (have been replaced just in case)... Turning on the aircon almost instantly throws the engine temp through the roof. The fan does work - because I can power it from an independant source.
 

·
Registered
2013 VW Golf Sportwagen TDI, 2011 Mazda 2, 2000 E320 4Matic Wagon (retired),1994 C280 (retired)
Joined
·
3,488 Posts
Thanks for the reply!

Fuses and relays are ok (have been replaced just in case)... Turning on the aircon almost instantly throws the engine temp through the roof. The fan does work - because I can power it from an independant source.
Sorry, that's all I've got for you. I've always found MercedesShop - Mercedes Benz Parts and Technical Information to be a better source for harder technical diagnostic help. There are more technicians who actively post in their tech help forum.
 
1 - 6 of 6 Posts
Top