Mercedes-Benz Forum banner

1 - 11 of 11 Posts

·
Registered
94 s420 98 s420
Joined
·
537 Posts
Discussion Starter #1
I purchased refills for the 94 s420 today and its almost impossible to slide on. Does anyone have a trick to this? There are 10 Tracks they must slide thru and I cant get past the 3rd. Should they slide on with eas or is this normal. Thanks
 

·
Registered
S600L
Joined
·
541 Posts
After removing the wipers from the car you can see the rubbers are held on and in position down their length by thin chrome strips.If you sqeeze both sides of one end together the cut outs will clear the retaining lugs on the wiper arm and you can then slide the old rubbers out.Refitting is just the reverse.Easy when you've done it a few times but baffling when first encountered[:(!]Just replaced mine before winter and I neglected to take photo's BUT next time I will!My replacement rubbers cost £25 for both as against£118 just for the drivers side complete wiper blade! [;)]
 

·
Registered
94 s420 98 s420
Joined
·
537 Posts
Discussion Starter #3
Thank you merc, It was time consuming and iam not even sure if the new blades they gave me are the right ones. I finally managed to slide them all the way down.
Another problem I have with the drivers wiper, is that it wont reach out to the corner like it used to. Would anyone know what can cause this, I opened the cover today and the transmission seems ok, nothing broken off. I can move the wiper in and out with my hands to adjust it so it wont hit the chrome moldings on the roof. Any suggestions as to why it wont reach to the conrner is appreciated.
 

·
Registered
S600L
Joined
·
541 Posts
What happens is eventually the nylon gear wears (or strips when wipers are turned on when frozen to windscreen),and when you try to obtain a replacement gear MB tell you you have to purchase the entire assembly at £1000 and Bosch won't supply you with the gear - even though they manufactured it[:(! My solution was to have a local engineering firm manufacture one for me for £15 and it was still running 2 years later when I sold that S class![:D]
 

·
Registered
1995 S500 Coupe
Joined
·
6 Posts
[?]My new Blades went on a little easier than bass1175, But now I am hearing a definite 'click' on the top of the swipe and a lesser one at the bottom.
We have had very little rain this year, so have not needed the wipers often.
Do the rest of you hear a 'click' or is the swiping back and forth completly silent??

Thanks for any posts
 

·
Registered
1997 S500
Joined
·
281 Posts
I had to "engineer" a rubber blade because I couldn't find the correct size at any of my local parts stores. Imagine that. From memory I believe that main wiper is a touch over 26" in length. I bought a 28" repacement blade for about $10. Took the blade home and simply cut it to the correct length. I used the old steel bands that straddle the rubber to insure a correct fit.

Now, the main wiper works fine but the second wiper, which is also new out of the box- unmodified, chatters as it makes it's sweep. I have a feeling this has more to do with chemicals or lack there of that are on the windshield. I've stripped the glass and tried various products but nothing seems to work very good. In fact, Rain-x seems to be the worst as far as making the wipers glide across the galss. Anyone have any ideas?

Another thing- I have never be able to figure out how to lift the arms off the glass to the poiint where that stay in an open or lifted position. Again from memory, I believe the owner's manual shows or mentions how to do this but I was never able to make it work.
Paul
 

·
Registered
S600L
Joined
·
541 Posts
To stop the wiper 'juddering' you need to 'slightly' twist the arm with a small adjustable spanner.This alters the 'angle of attack'of the blade on the windscreen and prevents the blade from making a noise and juddering[:)]
 

·
Registered
94 s420 98 s420
Joined
·
537 Posts
Discussion Starter #8
Both wipers were different in sizes one 28
(passenger)inch the other was 26 inch and I couldnt get the drivers wiper off, I had to do it in place. The passenger wiper would only come off with the hood opened all the way up. I had a clicking noise ontop and i noticed my wiper was hitting the chrome ring around the windshield. So i simply pushed the pistion which reaches out to the corner in a little, Something seems to be broken since I was able to go in and out as much as I want. I found a new tranny and motor for the drivers side on ebay, 125 for the whole assembly. I woul like to get my wiper to reach to the corner once again.
 

·
Registered
1997 S500
Joined
·
281 Posts
Bass1175

Good luck with the wiper replacement- that price sounds good- assuming the assembly is in good shape. You might of stated this earlier but do you know how it broke/wore out? How many miles are on your car?

MercS600

Fascinating! What a novel fix! I suppose it really doesn't matter which way you twist the are and I assume we're only twisting it a degree or two. Thanks for your help- once again!
Paul
 

·
Registered
94 s420 98 s420
Joined
·
537 Posts
Discussion Starter #10
Hey pc , it broke last winter with the previous owner ( cousin) there was so much ice built up on the windshield and a guy at the repair shop turned on the wipers. There was a big clunk and the wipers never worked after, so his father took it to another shop and they fixed it, however the corner feature never worked since. Iam still curious whats not connected, missing or broken.
I have so many small repairs on the car and i really cant keep up. I need two headlights as well, mine have pebble cracks from the highway, not sure to get those bosch lenses or buy after market fully assembeled headlights. Would like new mxv4 tires and while doing my plugs I found out I need a new injector harness, the insulation is all cracked.
For now i try to keep the engine and tranny as clean as possible. I replaced my plugs last weekend, I wanted to go stock with the champion plugs listed in the manual but the ride was horrible after, so I replaced them back with what my cousin had in there Bosch double platnium, big difference. Iam using mobil 1 0W-40 and the engine is not skipping a beat.
The one thing that motivates me to spend more money in this car, is the power beauty and comfort, Ive never been in a better ride. The car has 133k miles. Thanks for listening:)
 

·
Registered
S600L
Joined
·
541 Posts
Definately the plastic gearing - it stripped when they turned the wipers on with ice on the screen.Its located in the 'frying-pan' housing at the base of the wiper.A very easy fix when you have a new nylon gear.Apparantly the gear is made of nylon and not metal so it is a built in safety device as the rest of the 'gearbox' is made of 'monkey metal' and would require the whole unit replacing[:(!]As I stated previously you have to have one manufactured as Bosch and MB will not or are unable to supply just the gear[:0].You will unfortunately have to remove the old gear as a pattern - and also if you just turn the gear around it will still not work as the gear revolves comletely after a few cycles of the wipers[:(]
 
1 - 11 of 11 Posts
Top