Mercedes-Benz Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
142 Posts
Discussion Starter #1
My washer fluid is not spraying on the windshield or headlights, the tank is full anyone know the location of the pump or what is the problem.
 

·
Registered
Joined
·
11 Posts
My headlight sprays are OK but the windshield ones are horrible. The wiper blades make an entire pass on the dry windshield before the spray hits the glass. Really not ideal.

Does anyone have any thoughts? Could the pump have a blockage?
 

·
Registered
Joined
·
10,427 Posts
My headlight sprays are OK but the windshield ones are horrible. The wiper blades make an entire pass on the dry windshield before the spray hits the glass. Really not ideal.

Does anyone have any thoughts? Could the pump have a blockage?
Mine is the same. If windshield washers have not been used for a while, it takes quite a while before you get a good spray. I have not looked at the pump (quite difficult to reach on a car with a heated washer reservoir), feels like it should have a non-return valve but it is leaking.
 

·
Registered
Joined
·
142 Posts
Discussion Starter #7
Wow i've seen the motors for sale online for under $100.
Why was it such an expensive fix?
 

·
Registered
Joined
·
71 Posts
***************** ************************3.0*************** $447.00 ************** *$447.00 **************
PANORAMIC ROOF SUN SHADE MOTOR ELECT FAULT********************* 1************* 2118202742******** N/S******* $282.00 ************** **********1.0*************** $149.00 ************** *$431.00 **************
PANORAMIC ROOF MOTOR ELECT FAULT ******************************************************************************************** **********************************************************1.0*************** $149.00 ************** *$149.00 **************
WINDSHIELD WASHER PUMP ELECT FAULT*********** **************** ************** 1************* 2218690121************************ $32.00 **************************1.0*************** $149.00 ************** *$181.00 **************
GROMET***************************** ******************************************************************************* 1************* 1239973681************************ $2.90 ****************** ******************************* *$2.90 ** *****************$2.90
REC 'A' SERVICE* ENGINE OIL VERY LOW AND DIRTY************************* 1********************************************* ************** *$319.95 ******************************* ****************** *$319.95 ************** *$319.95
MOTOR MOUNTS COLLPASE*********************** *********************************************** 2************* 2202400617************************ $155.00 ************** **********5.8*************** $864.20 ************** *$1,174.20 **********
TRANS MOUNT COLLPASE*************************** *********************** ************************1************* 2212400918************************ $49.50 **************************1.0*************** $149.00 ************** *$198.50 **************
RT SIDE TRANS OIL COLLER LINE LEAKING***************************** *********** ****1************* 2212705496******** N/S******* $102.00 ************** **********1.5*************** $223.50 ************** *$325.50 **************
RT AND LT TORQUE STERUT BUSHING WORN AND CRACKED******** 2************* 2213330814************************ $37.50 **************************3.6*************** $536.40 ************** *$611.40 **************
 

·
Registered
Joined
·
10 Posts
Im having the same problem. the motor isnt hard to reach at all. im just wondering why the headlights spray but not the windshield. im wondering if it is clogged somewhere in the line? any thoughts or ideaas?
 

·
Registered
Joined
·
4 Posts
My headlights spay but not the windwhield. Do they have separate motors (pumps)? I believe they share the same reservior - correct?
 

·
Registered
Joined
·
6 Posts
They do have separate motors for the windshield spray and the headlight spray. I had the same problem and pulled up the reservoir to replace the windshield spray pump motors. The probelm I'm facing now is putting the reservoir back in. You see the headlight pump motor is connected to a really short pipe a the bottom. In order to connect it to the pipe, the reservoir really needs to be sitting in its place but if I seat the reservoir, there is not enough room to reach in there to connect the headlight spray hose to the headlight spray pump motor.

Has anyone does this? Can you post a video on YouTube showing how you installed it?
 
1 - 14 of 14 Posts
Top