Mercedes-Benz Forum banner

1 - 16 of 16 Posts

·
Registered
97' E 320 //////02' C240
Joined
·
88 Posts
Discussion Starter #1
:confused::confused:

Today while driving my Drivers side window went down by itself!

I pushed the button to get it to go up and that worked fine..... however a while later the window went back down all by itself again, this time I stoped it by pushing the button to make it go up, it worked , it stoped it from going down and it went up about 3 inches and then just stopped!

Now the window is half open and I am stuck...it wont go up or down, not sure whether it's the switch motor or regulator. All other windows work just fine and the Fuses are ok as well.

I do not think it is the regulator since the glass will not budge up or down it has about 1 inch of up and down play but it does not feel like it's about to come off the track.

Where do you think I should start? I'm Stumped!!!!

Any help would be appreciated!!! Thanks much!!!
 

·
Registered
1996 210.020
Joined
·
3,972 Posts
I would start with the switch. It is possible that it is making contact, giving the demand to lower the window. Does the switch feel any different from the other three?
 

·
Registered
'01-E320 & 02-ST2
Joined
·
31,633 Posts
It's also possible that whatever was recently spilled in the console has shorted out the switch, initially causing erratic behavior and now failing completely...
 

·
Registered
96 E-320, 91 190E, various and sundry Euro and American vehicles
Joined
·
12,141 Posts
To test.
Take out one of the other switches and swap it to see if it is indeed a switch. The swap isn't a rough thing to do. If nothing else, loosen the harness and swap it to another switch. That way you don't have to actually remove the switch from it's mounting. There should be enough harness length to do that. There was on my old 190E.

Aardvark
 

·
Registered
96 E-320, 91 190E, various and sundry Euro and American vehicles
Joined
·
12,141 Posts
Also try spraying some electronic contact cleaner in there. Don't get it all over everything. Best to do that with the switch out. LET IT DRY before using.
Aardvark
 

·
Registered
1996 210.020
Joined
·
3,972 Posts
I am fairly sure that you can't swap them around on the 210. They are all contained in one switch module, and do not have separate electrical connectors as were used in older models.
 

·
Registered
97' E 320 //////02' C240
Joined
·
88 Posts
Discussion Starter #7 (Edited)
Thanks for all the responses

The switch actually feels just like the others same clicking and feel..thanks though

I will definitely check on the switch first I have been looking on here to see how I can get to the switch ....but seems the search feature is not cooperating w/me tonight....can anyone advice me or send me a link?

Thanks again......
 

·
Registered
96 E-320, 91 190E, various and sundry Euro and American vehicles
Joined
·
12,141 Posts
Onyx.
I believe the wood mounting for the switches will pry up with a thin screwdriver (if anything like the older Benz's).

Aardvark
(Matt, correction?)
 

·
Registered
1996 210.020
Joined
·
3,972 Posts
Onyx.
I believe the wood mounting for the switches will pry up with a thin screwdriver (if anything like the older Benz's).

Aardvark
(Matt, correction?)
I think that all you need to do is first remove the plastic trim around the shifter, then open the ash tray door, and pull up on the edge of the wood trim. Be careful to pull it evenly so you don't crack the finish.
 

·
Registered
97' E 320 //////02' C240
Joined
·
88 Posts
Discussion Starter #11
Thanks for the tip Matt..........
I pulled off the wood trim and the switches are in fact held to gether all in one frame surrounding the shifter assembly...and they are not separate pieces.

There was some dust on the electronics board and I vacuumed it off.
It was totaly dry no water or moisture whatsoever.( I never drink or eat in the car anyhow)
The switches all feel the same, to find the culprit I took the door panel off and checked for Voltage at the power window motor plug.... When I hit the switch I got Nothing !...I am not sure how much Voltage is supplied to this motor but I will try another voltmeter......

Everything else seems fine with the mechanism all parts are intact and there was nothing loose laying around!

To get the window up I plugged a battery to the window motor and it barely moved up it moved a bit better on its way down I had to pull the window up while I had the battery connected to the motor to close the window .

The one thing I have figured out is that the motor is shot for good!

I am worried about not getting any voltage at the connector.

Any suggestions on where I can get the motor and what to use to lube the tracks?



Again Thank you all for all your Help!
 

·
Registered
1996 210.020
Joined
·
3,972 Posts
I have yet to hear of a failed window motor in a 210. I'm sure that it happens, but it must be very rare.
 

·
Registered
97' E 320 //////02' C240
Joined
·
88 Posts
Discussion Starter #13
What is the best way to check?

I plugged the motor directly to a battery and it barely moved at all... you got me thinking maybe the regulator is stuck or so but i had to push the window from the bottom while i had the motor plugged in to get it back up and it did glide up smoothly.

Should I take the motor out completely to see if it spinns freely out of the regulator?
 

·
Registered
2008 BMW 528i,1999 Lexus 400LS, 2014 e250 BlueTec
Joined
·
635 Posts
Window regulator check is rather easy thing to do so I would start from there. I have not heard of motor going either.
 

·
Registered
Joined
·
2 Posts
:confused::confused:

Today while driving my Drivers side window went down by itself!

I pushed the button to get it to go up and that worked fine..... however a while later the window went back down all by itself again, this time I stoped it by pushing the button to make it go up, it worked , it stoped it from going down and it went up about 3 inches and then just stopped!

Now the window is half open and I am stuck...it wont go up or down, not sure whether it's the switch motor or regulator. All other windows work just fine and the Fuses are ok as well.

I do not think it is the regulator since the glass will not budge up or down it has about 1 inch of up and down play but it does not feel like it's about to come off the track.

Where do you think I should start? I'm Stumped!!!!

Any help would be appreciated!!! Thanks much!!!
I have the same problem!! Any suggestions much appreciated!!!
 

·
Premium Member
1998 E320 base sedan @ 160kmiles
Joined
·
6,186 Posts
I have the same problem!! Any suggestions much appreciated!!!
Please update your profile with the model and model year of your car. The window control systems are different from model -year-to -year and from mode-l to-model.
 
1 - 16 of 16 Posts
Top