Mercedes-Benz Forum banner

1 - 20 of 21 Posts

·
Registered
01 ML55, 96 S320
Joined
·
299 Posts
Discussion Starter #1
Running the VIN decoder on here the stats for my 01 ML55 are:

357 Navigation System - Add'l Equipment
460 Canada Version
494 U.S. Version
522 Radio ICU "Alpine" USA

The 1999 ML320 being parted is:
258 Radio premium with soundsystem Bose, USA Version
494 U.S. Version

My radio is failing and I can get a local one for super cheap. Don't know if it will work though...

Thanks all
 

·
Registered
w163 02 ML500 W210 97 E50Amg w202 99 C230K w124 - need more space, time to build again
Joined
·
2,373 Posts
Wallyo,
Not too much re-wiring was needed on our FO '02. We kept our existing wiring harness that plugs into the amp (on the left side) because it contains all the existing wiring to all the speakers so why not reuse it. Wanted to re-purpose the "amp box connector" on the left side (that connects to the harness). Gutted innards of the amp so we could run the new double din wiring thru the shell of this amp box. Followed the DIY posted on wiring scheme of the Bose setup and harness.
Done.

Screen Shot 2020-01-27 at 7.28.25 AM.png
 

·
Registered
2003 ml500, 2004 ml350
Joined
·
1,093 Posts
Wallyo,
Not too much re-wiring was needed on our FO '02. We kept our existing wiring harness that plugs into the amp (on the left side) because it contains all the existing wiring to all the speakers so why not reuse it. Wanted to re-purpose the "amp box connector" on the left side (that connects to the harness). Gutted innards of the amp so we could run the new double din wiring thru the shell of this amp box. Followed the DIY posted on wiring scheme of the Bose setup and harness.
Done.
You posted before I deleted my response. I think the poster is just trying to have a direct plug and play replacement.
I first said no because I knew the amp changed a 2000-2005 amp is163-820-30-89, an 1998-1999 is 163-820-12-89.

But according to Mercedes the head unit is the same for all years. 163-820-36-89-8?
 

·
Registered
01 ML55, 96 S320
Joined
·
299 Posts
Discussion Starter #5
Correct, plug and play is ideal for a cheap alternative. I’m not sure I want to spend $170 to get mine repaired. It’s either go cheap with a local or spend more and get something modern.
 

·
Registered
2003 ml500, 2004 ml350
Joined
·
1,093 Posts
I think the number I used above 163-820-36-89 is a Mercedes remanufacture number and covers many models. But is is the only one listed for ML head units on benz part sites.
 

·
Registered
2003 ml500, 2004 ml350
Joined
·
1,093 Posts
Here is a link to, though short one of the best explanations of the differences between ML audio systems.

According to the info there a 99 and 2001 head unit should interchange. I would pull my head unit and compare it to the one you are thinking of. What are they asking for it? there are hardly any on ebay

 

·
Registered
1999 ML430; 1998 S420
Joined
·
235 Posts
There were five models of the stereo. RA4910 was in 1999/2000 MLs that did not have fiber optics. However, the green plug on the back covers up the fiber optic light, so I'm not sure if it will send the fiber optic light to ML's that have fiber optics.
RA4110 - 2001
RA4210 - 2002
RA4310 - 2003
RA4410 - 2004 and 2005
If you put any of the 2001 to 2005 models into a 99 or 2000 ML without fiber optics, it will work, it just won't control the six disc changer. I'm just not sure what happens if you put an RA4910 into an 01-05.
 

·
Registered
2003 ml500, 2004 ml350
Joined
·
1,093 Posts
I can not remember what year the Jump was 03 maybe, but I do know that the navigation went from multiple CD's for each zone to One ROM DVD. That was one difference in the various head units.

I think 1998 -2000 did not have navigation, the first year with navagtion 2001.
 

·
Registered
01 ML55, 96 S320
Joined
·
299 Posts
Discussion Starter #10
Great info in these threads, thanks again all.

I told the 99s owner I would give him $25 and he said I had to take it out. Done. Bit of a drive but I will grab it soon and see what's up. Hoping I can call MB with the VIN and get the code if he doesn't have it?
 

·
Registered
1999 ML430; 1998 S420
Joined
·
235 Posts
Shoot me the serial number and I’ll get you the code. Really interested to hear if it controls your CD changer.
 

·
Registered
w163 02 ML500 W210 97 E50Amg w202 99 C230K w124 - need more space, time to build again
Joined
·
2,373 Posts
Great info in these threads, thanks again all.

I told the 99s owner I would give him $25 and he said I had to take it out. Done. Bit of a drive but I will grab it soon and see what's up. Hoping I can call MB with the VIN and get the code if he doesn't have it?
MB will provide it. Provide them the serial # on the radio.
 

·
Registered
2003 C320 coupe, 2000 ML320
Joined
·
725 Posts
Hey Ed... I'm looking for a junked radio with a GOOD display... What's wrong with your's ?
Does it look like the one I put up.. If so,.. let's talk
2618500
 

·
Registered
01 ML55, 96 S320
Joined
·
299 Posts
Discussion Starter #14
Hey Ed... I'm looking for a junked radio with a GOOD display... What's wrong with your's ?
Does it look like the one I put up.. If so,.. let's talk
View attachment 2618500
HI Bobby. The FM is no longer working on mine. I can barely hear it when I crank the knob up all the way. Other things are fine. you're more than welcome to the display on either one of these.
 

·
Registered
01 ML55, 96 S320
Joined
·
299 Posts
Discussion Starter #16
Little update. Got a blue screened radio with nav from a guy but still the same issue. No FM and everything else works great.

not sure the year this blue screener was from but connections are the exact same. Why did MB go with a blue screen? Reminds me of the old school weather channel local on the 8s
 

·
Registered
w163 02 ML500 W210 97 E50Amg w202 99 C230K w124 - need more space, time to build again
Joined
·
2,373 Posts
Little update. Got a blue screened radio with nav from a guy but still the same issue. No FM and everything else works great.

not sure the year this blue screener was from but connections are the exact same. Why did MB go with a blue screen? Reminds me of the old school weather channel local on the 8s
Subliminal MB ADs on the UV frequency.
 

·
Registered
2003 ml500, 2004 ml350
Joined
·
1,093 Posts
Got a blue screened radio with nav from a guy but still the same issue. No FM and everything else works great.
Chances are it is the noise canceling mic

See here

 

·
Registered
Dallas, Texas
Joined
·
7,360 Posts
Little update. Got a blue screened radio with nav from a guy but still the same issue. No FM and everything else works great.

not sure the year this blue screener was from but connections are the exact same. Why did MB go with a blue screen? Reminds me of the old school weather channel local on the 8s
No FM as in no reception? Most likely poor ground or power supply to antenna amp. Antenna signals can be checked using SDS.

Screen color can be changed using SDS. Mine is set to Gray. Dark mode.
 
1 - 20 of 21 Posts
Top