Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
1997 SL500
Joined
·
4 Posts
Discussion Starter #1
I recently joined this forum and purchased a 1997 SL500. It's in good shape, but the one-button remote control works sometimes and not others. It works with all 3 sensors at times, but sometimes with none of them. The blinking red and green lights on the sensors don't usually flash except the red on the driver's door.

So my mechanic recommended that I purchase a new key/remote and syncornize it by turning it on for 30 seconds. Now that remote works pretty consistently with the driver's door sensor but not with the other 2.

Any idea why I would have this problem or what I should do next?
 

·
Registered
2000 SL500
Joined
·
106 Posts
When was the last time that you replaced the batteries? My old 97 remote used to act really flakey when the batteries were low. I would spend the $5 first on the batteries before you spend the $160 for the new remote.
 

·
Registered
97 SL500
Joined
·
1,259 Posts
in my opinion benz remote suck, they use light like tv

remote controllers do and you basically have to be right on the car before they operate. if you really want to improve your system have a keyless entry remote installed from an audio/alarm shop. then again, do u really want somebody messing w/your car just for that? i just bit the bullet and kept my benz remote. try new batteries.
 

·
Registered
97 SL500
Joined
·
1,259 Posts
i would not buy a new remote to reprogram either. honestly, i

dont use my remote, its clumsy, bulky and it doesnt work worth a crap. i always carry the flat key in my keychain.
 

·
Registered
2009 SL550 Silver Arrow Launch Edition, 2013 Mercedes Benz C300 4Matic
Joined
·
986 Posts
I had the same problem a month ago. Dealer told me the remote was bad, etc. etc., cost of $165.00...It was the batteries.[:0]
 

·
Registered
1999 SL500
Joined
·
25 Posts
I have a 99 and my remote uses regular watch batteries which are available at any CVS, food store or hardware store. I forget the number but its in the users manual.
 

·
Registered
SL500, CL55, E350, E320
Joined
·
3,205 Posts
Thanks. If I don't drive the car for more than 3 weeks, the remote works just fine. If I drive it often, it works on and off. I guess I will check out the battery.
 
1 - 8 of 8 Posts
Top