Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
1983 300 SD; 2000 E320
Joined
·
1,099 Posts
Discussion Starter · #1 ·
When I accelerate forcefully in my SE I hear a whistle/ whining noise for as long as I accelerate. Sounds like the engine. Is this normal?

thanks
 

·
Registered
1983 300 SD; 2000 E320
Joined
·
1,099 Posts
Discussion Starter · #3 ·
Can it be my belt and pulleys if the noise doesn't occur when I rev it up in Neutral?
 

·
Registered
1962 220S(200d engine),1970 Cadillac Fleetwood 75,1984 500SL
Joined
·
442 Posts
seems like a lot of people have this problem of whistling under high rpms in drive...has any one figured out what causes this? or is everyone just driving down the road whistling a tune?
ive changedall seals and hoses for intake thinking it was a vacuum leak, checked exhaust, pulleys, ect...trying to figure this out...lot of people have this problem anyone figure it out?
 

·
Premium Member
2004 S500 4Matic, 2018 Ford Expedition Max, 2017 Jaguar F-Pace S, 2016 BMW 750i
Joined
·
514 Posts
The inline six has a reputation for a drive belt whine. Mine has it the belt is new. Could also be a vacuum leak somewhere in the firewall area, but my money is on the serpentine belt.
John
 

·
Registered
1962 220S(200d engine),1970 Cadillac Fleetwood 75,1984 500SL
Joined
·
442 Posts
The inline six has a reputation for a drive belt whine. Mine has it the belt is new. Could also be a vacuum leak somewhere in the firewall area, but my money is on the serpentine belt.
John
i have a v8 belts were just replaced and what vacuum lines are on the firewall that can cause a fluctuating whistle only at high rpms in drive..?
 

·
Registered
W126 420SE & W126 300SE
Joined
·
389 Posts
I have this problem as well. Has anyone found a possible cause yet?
 
1 - 7 of 7 Posts
Top