Mercedes-Benz Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
I recall reading a thread on this about a year ago but I cannot find it. When my car idling, a whining sound is heard coming form beneath the dashboard. When I accelerate, the noise goes away. Can someone tell me what is causing this and how I can fix it?

Thank you!

WAE
 

·
Registered
'85 2.3-16 '99 C280 '11 GLK350
Joined
·
4,804 Posts
It would help if you could "localize" the source of the sound. Left, Center or Right? There are only a few whirring sound sources are under the dash. The speedometer cable spins on the left, the heater blower motor is behind the center console and the cabin temp aspirator motor is on the right, behind the glove box.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3
It is on the driver’s side beneath my feet. It goes away when I accelerate and returns at idle.

Thanks,

WAE
 

·
Registered
1999 C280
Joined
·
898 Posts
Anybody know whats wrong on my 85 190D. I am getting an almost constant clicking noise from over by the glovebox when my temp dial is set on anything but the hottest hot or the coldest cold?

Thanks
 

·
Registered
'85 2.3-16 '99 C280 '11 GLK350
Joined
·
4,804 Posts
For the driver's feet, probably the speedo cable, where it's running down the firewall.

As for the glovebox, as stated above, there's a motor/fan mounted there that is used as part of the temp sensor located in the center of the roof, between the sun visors.
 

·
Registered
1996 C180/1983 280SL
Joined
·
57 Posts
wae96 said:
I recall reading a thread on this about a year ago but I cannot find it. When my car idling, a whining sound is heard coming form beneath the dashboard. When I accelerate, the noise goes away. Can someone tell me what is causing this and how I can fix it?

Thank you!

WAE


hello ! my 1996 C180 (W202) is showing the same problem (aparently). Try turning the air conditioning off and check if the noise is still there. There are good chances you have a vacuum leak.

I have not fixed mine yet, so I cannot be precise. But from what I have talked to my friends that own Benzes, this should not be a major issue.

Good luck.
 

·
Registered
1985 w201 Euro 2.3-16vlv / 1992 w201 2.6 Sportline Manual
Joined
·
6,726 Posts
Mad props on helping a guy who posted a thread 2 years back :thumbsup:
 

·
W201, W202, W203, W204, W205 Moderator
Amethyst 2001 C320
Joined
·
1,733 Posts
Kynyption said:
Mad props on helping a guy who posted a thread 2 years back :thumbsup:
lol, looks like the answer was given back in '05. Old thread btw!

mfagus said:
Anybody know whats wrong on my 85 190D. I am getting an almost constant clicking noise from over by the glovebox when my temp dial is set on anything but the hottest hot or the coldest cold?

Thanks
Since you posted this question 2 years ago, who knows if you'll see this, but the clicking noise is coming from your vacuum distributor which is behind the glove box.
 

·
Registered
1996 C180/1983 280SL
Joined
·
57 Posts
his problem may or may not have been solved. But it may be interesting to know that if new posts are added to the thread, it goes back to the top of the viewing list. (at least it should :) )

And even if his problem has been solved, which I hope it has, there certainly are other people around the world, like myself, with the same problem, searching for the solution.

This is a Mercedes-Benz afficionado Forum, and the whole point here is to have fun helping and being helped. Discovering solutions for problems (ours and others) and using our experience and inteligence for upgrades.

Enjoy your MBs. Hope it takes long until they need any service, but when time comes, this is a cool place to come by.
 

·
Registered
mercedes-benz 190E 1.8 '91 102.910engine,mazda 1.6crtd dec'05
Joined
·
189 Posts
good to know it ,
i heard sometimes noises..........
 

·
IR MODERATOR
1996 Volvo 855GLT, 1993 MB 190e 2.3 8v, 1998 Subaru Outback SUS, 1991 BMW 525, 1998 MB C230
Joined
·
9,228 Posts
my 85 had the clicking noise and it went away and never came back
 

·
Registered
1985 w201 Euro 2.3-16vlv / 1992 w201 2.6 Sportline Manual
Joined
·
6,726 Posts
EnricoDePaoli said:
his problem may or may not have been solved. But it may be interesting to know that if new posts are added to the thread, it goes back to the top of the viewing list. (at least it should :) )

And even if his problem has been solved, which I hope it has, there certainly are other people around the world, like myself, with the same problem, searching for the solution.

This is a Mercedes-Benz afficionado Forum, and the whole point here is to have fun helping and being helped. Discovering solutions for problems (ours and others) and using our experience and intelligence for upgrades.

Enjoy your MBs. Hope it takes long until they need any service, but when time comes, this is a cool place to come by.

Key word there.
 

·
Registered
1997 E420
Joined
·
8 Posts
Does anyone have the part number (and official description) for the vacuum distributor/modulator which makes the infamous clicking noise behind the glove box?
 

·
Registered
500E, E320 Wagon, C32
Joined
·
227 Posts
MTI said:
It would help if you could "localize" the source of the sound. Left, Center or Right? There are only a few whirring sound sources are under the dash. The speedometer cable spins on the left, the heater blower motor is behind the center console and the cabin temp aspirator motor is on the right, behind the glove box.
My whining sound is coming from the right so I suppose it's coming from the cabin temp aspirator motor. What do I do now to remove the thing that's causing the whining sound (although it does disappear after a while but is replaced by a motor sound). Both of these sounds are new sounds to me.

Will this lead to anything worse that just the sounds?
 

·
Registered
500E, E320 Wagon, C32
Joined
·
227 Posts
Bump... Anyone???

Cabin Temp Aspirator Motor producing a whining sound. How do I fix this?

Will this lead to something worse if left unattended?
 
1 - 16 of 16 Posts
Top