Mercedes-Benz Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
711 Posts
Discussion Starter #1 (Edited)
sorry to post a new thread...

i am on to replacing 3rd item dealer recommended...suggests replacing lateral accel sensor for c1142 code.

i found these 3 parts under center console and don't know which is which:

a1635426340
a1635420618 accelerometer $94
a1635425032

i could only find one above i middle...is this the lateral accel sensor?

when i use epc for vin4JG1631541A273652 picture on epc does not look anything like below pic which i found on the forum and looks just like mine.

box to middle left with 2 bolts...what is it?
box with orange label...what is it?
small box bottom of pic middle on top of box with orange label?
 

Attachments

·
Premium Member
Joined
·
16,759 Posts
Scott, the Lateral Sensor is the small part indicated by the arrow.

Why don't you state what your problem is and what parts M/B said you had to change. It is almost impossible that 3 parts become faulty at the same time
 

Attachments

·
Registered
Joined
·
6,646 Posts
B43 is lateral acceleration sensor, B45 is yaw rate sensor. Box below with orange label is crash sensor/SRS control module.
 

Attachments

·
Registered
Joined
·
711 Posts
Discussion Starter #5 (Edited)
She say's it is first light bas/esp that comes on intermittently and sometimes a wheel locks up momentarily. "tech found code c1101 right front speed sensor, c1142 esp lateral sensor and c1200 brake lamp switch and suggests replacing cheapest first and progressing from there"

And actually all 3 lights were on sometimes. So i replaced brake pedal switch and it got replaced again last week for recall. And then only first light bas/esp comes on. Couple days ago replaced front right speed sensor. did not fix problem. no problem. i don't mind trying for $100 saves me money on paying them to read codes.

So before i buy part i wanted to be sure what to buy of the 3 items pictured. so frustrating thing today is that i emailed dealer what part#and cost is for "lateral acceleration sensor" they said "Part number is 002-542-89-18. Price is 680.00 and would have to be ordered. Would you like me to order it for you?"

I have no idea what they are talking about because that is not part# for any of the 3 items I listed.

It looks like you are both in agreement that b43 is indeed this sensor, right? So if you even think this sounds like it might fix the problem please let me know and i will get price and replace. intermittent problems suck...I already checked abs pump runs fine...a number of mos ago i checked all relays were ok. although they are all original.

Thanks!

I am still confused about which screen in epc would show these parts...I could not find.
 

·
Registered
Joined
·
711 Posts
Discussion Starter #7
I just was looking at epc and studying that screen you referenced. i think our vin ending with a273652 indicates separate turn rate and lateral accel sensor. dealer quoted the combined part which i dont think is applicable...i can check with dealer tomorrow. if they were combined is it fair to assume it would not look like the picture?

it is only $94 for lateral accel sensor...you think it might work? or don't want to comment?
 

·
Premium Member
Joined
·
16,759 Posts
I just was looking at epc and studying that screen you referenced. i think our vin ending with a273652 indicates separate turn rate and lateral accel sensor. dealer quoted the combined part which i dont think is applicable...i can check with dealer tomorrow. if they were combined is it fair to assume it would not look like the picture?

it is only $94 for lateral accel sensor...you think it might work? or don't want to comment?
Scott, the dealer looked up the wrong part #. 002 542 89 18 is for MY 2003 and up and does not apply to your truck. If you want to replace the Lateral Sensor just order 163 542 06 18 which is the correct part.

After you replaced the brake switch and the R/F speed sensor, is the wheel still locking up or your issue is with the lights still being on? After every repair the codes must be erased with the proper scanner and then test drive to see what codes if any reappear.
 

·
Registered
Joined
·
711 Posts
Discussion Starter #9
The issue is with light and lock up being intermittent...I think i will go for the lateral sensor. I will not hold you to any result. I just wanted to confirm the part# and eliminate the confusion that dealer created. THanks again.
 

·
Purple Moderator
Joined
·
21,701 Posts
I do when working on electronics.
You will have to turn the steering lock to lock a couple of times to turn off the BAS and ESP lights.
Not sure about the windows auto up feature, mine does not have it. If you do put the windows all the way down. Then for each one hold the switch as they go up and continue to hold it for 10 seconds.
Also know your radio code. It will need to be entered.
 

·
Premium Member
Joined
·
16,759 Posts
I do when working on electronics.
You will have to turn the steering lock to lock a couple of times to turn off the BAS and ESP lights.
Not sure about the windows auto up feature, mine does not have it. If you do put the windows all the way down. Then for each one hold the switch as they go up and continue to hold it for 10 seconds.
Also know your radio code. It will need to be entered.
Noodles, it is not necessary to disconnect the battery. The Lateral Sensor is a dead issue if the engine is not running. Doing so in this instance will only reset all the monitors and cause resync of unnecessary items.
 

·
Purple Moderator
Joined
·
21,701 Posts
Got it. I am so paranoid because of all the things my W211 have that I guess I am being overly cautious.
Thanks for the heads up.
 

·
Registered
Joined
·
711 Posts
Discussion Starter #15
thanks to all...i switched it out...the whole center console area comes out nice and easy with just six screws once you know how...and of course the more times you do it the easier.

it will be interesting to see if it fixes the problem.

i understand you get what you pay for but the funny thing was that when wife picked up this sensor the parts guy was like telling her that this would fix her problem. he said so assuredly that i was thinking "hey if you were that sure it was the lat sensor then why did you sell us the wheel sensor last week."

whatever, 2 sensors a hundred a piece. if it fixes it great if not oh well. intermittent problems suck.

there is just too much technology keeping us safe.

used to be when something broke on your car you could tell it by looking at the part directly.

oh well. i'll post in a few days if it works or later tonight if light comes on, meaning it did not work. lol.
 

·
Purple Moderator
Joined
·
21,701 Posts
I would go ahead and follow the highlighted steps in the PDF.

I always did test the the sensors in a similar manner, but I thought you were initially asking if it had to done by a dealer or shop with a MB SDS computer. Sorry for any confusion.
 
1 - 18 of 18 Posts
Top