Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
S600 W221 V12
Joined
·
171 Posts
Discussion Starter #1
Hello there.

Im positive my Airmatic Pump is gonna go on the blink.
For a few months now it has been making a helluva loud noise, and i think ive just been lucky it hasnt quit already.

It starts not long after starting the car and will come on every now and then.
After checking some posts this sounds like I might have a leak.

But the cars level and isnt lopsided in any way. Im thinking the pump should come on a few times when driving and if you have a pump thats quiet you wouldnt even notice it, but according to some posts this suggests a leak.

Im no mechanic, but the pump coming on for maybe 20 seconds when starting first thing in the morning, then again after half an hour should be ok, eh? As I said Im no mechanic! :( Is that not normal??

I will have a look at some posts to see if I can find one for a D.I.Y. leak test.

Anyone know where I can purchase the pump in the UK? Ive found one in the link below, but is there any other places i could try?

Thanks in advance.:thumbsup:

Parts for Mercedes-Benz:
 

·
Registered
s320 white
Joined
·
68 Posts
go to your local dealer for the pump. I just bought it from them for £235 inc vat.

they in stock.

its sounds like the pump you have operating ok, but what is the noise like?
 

·
Registered
S600 W221 V12
Joined
·
171 Posts
Discussion Starter #3
Hi.

Thanks for the reply.
Just sounds the way a pump would sound if it was really struggling.
Heavy vibration sounding noise. Im gonna wait till its a good day as ive read in one of the forums that maybe the 3 bolts are maybe loose and thats causing
the noise.

The reason i think its definitely the pump is, back in my youth when I used to work in a coffee shop the pump that fed the espresso machine made the same noise when it was time to replace! :D Same sort of thing maybe!! Haha.

Cheers
 
1 - 3 of 3 Posts
Top