Mercedes-Benz Forum banner

1 - 13 of 13 Posts

·
Registered
1996 S420
Joined
·
48 Posts
Discussion Starter #1 (Edited)
Hi folks,
I am looking for an entire central lock vacuum pump motor assembly. I purchased a new motor, but the ceramic (?) pieces that go on the shaft just fell to pieces. I'd like to locate just the motor w/ceramic pieces or just the ceramic pieces so I can press them on myself, instead of purchasing the entire vacuum pump. This is for a 96 s420. Thanks for any leads!
Chris
 

·
Registered
94 s420 250kmiles
Joined
·
827 Posts
the door lock pump or the close assist?

if its the close assist i have one spare, tested working, and adjusted to shutoff at a little lower pressure.
 

·
Registered
1995 S 420, 2012 GLK 350 and 1997 Audi Cabrio; Previously 1982 280CE, 1974 450SL, 1974 911S Targa
Joined
·
456 Posts
Hi folks,
I am looking for an entire central lock vacuum pump motor assembly. I purchased a new motor, but the ceramic (?) pieces that go on the shaft just fell to pieces. I'd like to locate just the motor w/ceramic pieces or just the ceramic pieces so I can press them on myself, instead of purchasing the entire vacuum pump. This is for a 96 s420. Thanks for any leads!
Chris
check with eddie a up in BAH-STAN...
 

·
Registered
1997 S500V, 1999 S500 grand edition, 2006 s65 amg
Joined
·
7,356 Posts
the door lock pump or the close assist?

if its the close assist i have one spare, tested working, and adjusted to shutoff at a little lower pressure.
do you live near Hollywood? if you do can i test your pump on my car? i am trying to figure out why the pump stops one each door after 2-3 tries. i adjusted it but it fells like it lost pressure
 

·
Registered
1995 mercedes S420
Joined
·
228 Posts
do you live near Hollywood? if you do can i test your pump on my car? i am trying to figure out why the pump stops one each door after 2-3 tries. i adjusted it but it fells like it lost pressure

i had that problem bro. that means u got air leak somewhere.
i bought a new pump, the problem was still there, than a mechanic told me there's a leak, i found it , fixed it. now the doors closing all the time
 

·
Registered
1997 S500V, 1999 S500 grand edition, 2006 s65 amg
Joined
·
7,356 Posts
i had that problem bro. that means u got air leak somewhere.
i bought a new pump, the problem was still there, than a mechanic told me there's a leak, i found it , fixed it. now the doors closing all the time
I cant hear any leaks and two of the valves on the pump are garbage. Also my pump is weak. I traced a air leak in a e420 and it was very simple. All you do is remove all panels and test them one by one which i have done i have one bad actuator on my drivers door. The rest work good also my rear right door actuator is bad too my trunk use to not suck and i changed and actuator and bam it works :) plus all of my hoses were replaced in 06 according to the service record
 

·
Registered
1995 S 420, 2012 GLK 350 and 1997 Audi Cabrio; Previously 1982 280CE, 1974 450SL, 1974 911S Targa
Joined
·
456 Posts
i had that problem bro. that means u got air leak somewhere.
i bought a new pump, the problem was still there, than a mechanic told me there's a leak, i found it , fixed it. now the doors closing all the time
Where was your leak; in a vacuum line or an actuator? I adjusted my pump shut off and all worked fine for about 8 months...now I've got issues with the two front doors again.
 

·
Registered
1995 mercedes S420
Joined
·
228 Posts
Where was your leak; in a vacuum line or an actuator? I adjusted my pump shut off and all worked fine for about 8 months...now I've got issues with the two front doors again.
i used cigarettes smoke to find out the leaks(blow the smoke in the hose. i had 2 leaks. 1 in the trunk and 2 in the driver side, i had to take the panel off
 

·
Registered
several
Joined
·
23 Posts
I buy alot of my parts from eaceuroparts .com you can always take a look and see if tthey have what you need. The prices are ussually pretty good.
 
1 - 13 of 13 Posts
Top