Mercedes-Benz Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
98 Posts
Discussion Starter #1
This is another quirk of mine that my car does...When I totally punch it to the floor ..my car does not take off until I ease back on the gas a little...Anyone know what this could be?

And what could I do to improve this if it is not normal...?
 

·
Registered
Joined
·
484 Posts
Depends on the gear and rpm. If u punch it to the floor in second gear, on 2500rpm it will take of for shure.
 

·
Registered
Joined
·
153 Posts
how do you get the best acceleration? kickdown right away? or i've heard from professional drivers that smooth is fast, what do you guys think?
 

·
Registered
Joined
·
2,398 Posts
You got TC dont think it makes much diff TBH
 
L

·
Guest
Joined
·
0 Posts
This is another quirk of mine that my car does...When I totally punch it to the floor ..my car does not take off until I ease back on the gas a little...Anyone know what this could be?

And what could I do to improve this if it is not normal...?

Sprint Booster !!! Highly recommended to solve your lag problem.
 

·
Registered
Joined
·
14,926 Posts
This is another quirk of mine that my car does...When I totally punch it to the floor ..my car does not take off until I ease back on the gas a little...Anyone know what this could be?

And what could I do to improve this if it is not normal...?
If you review the Owner's Manuel it states that putting the car in fourth gear will cut the response time quite a bit. In town this is no problem, out on the open road you obviously still want it in fifth gear.

Something that also might help is to reset the computer parameters. The directions are in the "stickys" up top of the page. Th car may still be working with the previous owners parameters.
Pulling off the negative battery lead for half an hour will do the same thing, just takes longer..... :)
 

·
Registered
Joined
·
98 Posts
Discussion Starter #8
I did some research on the sprint booster and I don't want to stir that up again....Damn! That was heated! I get what it does and read all the theroy's on it. Looks like personal preference to me...at the same time I did not see anyone have and say they didnt like it. Im gonna try reseting the CPU first. From what I've gathered I should get my pulley move my MAF and hookup the airbox before worrying about a SB.

thanks guys...just knowing the throttle is run through electronic devices pretty much sums the issue to me. I have to face the fact my blown and modded out Regal is always gonna be faster.

love the site
 

·
Registered
Joined
·
693 Posts
remember its drive by wire..

the accelerator cable is connected to a potentiometer which activates a servo to move the throttle..there may be something wrong there. I had that problem in my ML55 POS. then one day I was driving and the throttle stuck wide open! thats pretty sporty in traffic! I was just reaching to shift into neutral and blow the engine when it popped loose.:eek:
 
L

·
Guest
Joined
·
0 Posts
His car is a pre-2000 model, so it does not have a true drive-by-throttle. And there's only one way to reset the ECU without having the dealer computer. The other way where people, turn the ignition on, then step on the gas and hold it for 5 second. Then turn the ignition off then take your foot off the gas and wait for at least 2 minutes. This proecude is to reset the throttle only Not the ECU. Resetting the ECU is much better. I try both way on all my cars and the disconnect the battery way best.
 
1 - 11 of 11 Posts
Top