Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
280 SE 1976,S 600 1985,190E 1992,300 SDL 1986....And yea there are more to come.Stay tuned!
Joined
·
206 Posts
Discussion Starter #1
Good afternoon.
What would be the probable cause of windshield wipers stopping as soon as you turn them off?:confused:
They dont park properly and its intermittent,is there a park switch somewhere?
Its a 1986. 126,125
Thanks
Big Dan
 

·
Registered
280 SE 1976,S 600 1985,190E 1992,300 SDL 1986....And yea there are more to come.Stay tuned!
Joined
·
206 Posts
Discussion Starter #3
No park switch, more than likely an alignment problem.
How do you mean an alignment problem,are you talking about the wiper arms?
 

·
SuperModerator
1986/1990 W126
Joined
·
14,137 Posts
According to a thread not long ago, there is a relay and if you clean the contacts or perhaps change the relay it might solve the problem. Search 'windshield wipers'. It was only a couple days ago maybe.
 

·
Registered
Joined
·
32 Posts
As of yet I haven't had to work on a Mercedes wiper motor but I don't see any reason why they'd be any different than other brands.

In the wiper motors that I've see that do not park when the wiper switch is turned off there is an electrical contact on the larger gear inside the motor that gets dirty or warn so power isn't supplied to park the wipers.

This electrical contact on the larger gear inside the wiper motor doesn't make a full 360 degree circle. So, where the ring stops is where the wiper motor stops and that should be in the "park" position.
 
1 - 5 of 5 Posts
Top