Mercedes-Benz Forum banner

2021 - 2040 of 2053 Posts

·
Premium Member
1997 C140 S500, 2003 CLK430 Cab, 2005 E320 4MATIC Wagon
Joined
·
109 Posts
Replaced the Heater T Connector after failure, only issue is the hose clamps but not a difficult change. Now time for the full detail!
 

·
Registered
1999 S600
Joined
·
212 Posts
Started my sunroof resot today.. Got a buch of debris and a few lbs of roof insulation out. Took the slider to an upholstery shop to be recovered, hopefully they can salvage the original material...

HUGE shout out to Mafia Don for the excellent DIY write up!
2602101


2602102
2602103
2602104
2602105
2602106
 

·
Registered
1999 S600
Joined
·
212 Posts
Yanked the front bumper to attempt to repair, too far gone and the side clip that slides onto the bracket by the wheel well was broken off. New one on order, $177 + 135 S&H. It'a a new aftermarket bumper, I'll post an update when I receive it to comment on finish and quality.
2603091
IMG_4677 4.jpeg
2603093
 

·
Premium Member
1999 S600 & 1999 S500
Joined
·
802 Posts
I had PO301 to 306 codes and so I changed all 12 plugs and boots. Plugs are 60K miles old so it is probably time anyway. Changed coils on 1-6, based on misfire codes. Also changed coil on #12 since it is difficult to get to. You have to loosen the wiring harness tray to gain easy access. #11 was done by the dealer a few years ago. I replaced #10 because the tip broke off when I removed the boot. Seems to run better , but have not driven on the road yet. Will watch to see if codes come back.

May order a new MAF Sensor since I also got a PO170 code.
 

·
Premium Member
'97 CL600
Joined
·
2,844 Posts
I had PO301 to 306 codes and so I changed all 12 plugs and boots. Plugs are 60K miles old so it is probably time anyway. Changed coils on 1-6, based on misfire codes. Also changed coil on #12 since it is difficult to get to. You have to loosen the wiring harness tray to gain easy access. #11 was done by the dealer a few years ago. I replaced #10 because the tip broke off when I removed the boot. Seems to run better , but have not driven on the road yet. Will watch to see if codes come back.

May order a new MAF Sensor since I also got a PO170 code.
It may be too late, but I did the same with all 12 coils. However, I found the identical Bosch coils at amazon.com for half the price the dealer wanted.
Anziani
 

·
Premium Member
1999 S600 & 1999 S500
Joined
·
802 Posts
It may be too late, but I did the same with all 12 coils. However, I found the identical Bosch coils at amazon.com for half the price the dealer wanted.
Anziani
I think I bought my coils from Autohaus several years agoat $50-55 each. Much less than dealer. I just found the MAF on Amazon for $110. Finding inexpensive parts is almost as much fun as searching for a replacement W140, C140 or R129!
 

·
Premium Member
1999 S600 & 1999 S500
Joined
·
802 Posts
I replaced my radiator hoses (22 years old?), new coolant and a new air intake thingy . Car runs like a dream!
I probably need to replace both intake air filters. I can still feel a little shaking in the seat at idol. I am sure it is time to finally replace the engine & Tranny mounts.
 

·
Registered
Vogon constructor fleet.
Joined
·
9,208 Posts
Let’s see....

Distributor caps and rotors, new wires, plugs and ignition coils, cleaned out the EGR, throttle body and MAF and still had energy for a bit of interior detailing.

Tomorrow, renew the hydraulic fluid in the reservoir and get an alignment.
 

·
Registered
1999 S600
Joined
·
212 Posts
Since the new bumper didn't fit, I cobbled together a solution to get the old one back on with some gorilla tape and a metal bracket...

If anyone wants a FREE bumper, you're welcome to come and grab it if you think you could make it fit. It's doable, I just don't have the skills or resources to make it happen.
 

Attachments

·
Registered
99 SL500, 88 560SL, 97 S500, 87 BMW 635 CSi
Joined
·
40 Posts
Finished repairing the Duovalve with new seals and gaskets. I was hoping to fix a problem with the rear seat air pushing hot air when the A/C is running. Oddly, one of the vents blows cold A/C now and the other blow warm air.
2608768
 

·
Registered
94 - S500 Cpe
Joined
·
352 Posts
I ‘ve driven my ’94 S500 cpe for 20 years . . . and it’s now 25 yrs old. It’s been the most reliable Mercedes that I’ve ever owned with maintenance costs being minimal. After I retired, it has spent a lot of time in the garage for lack of driving.

So it was time to give it some love . . . as this thread says.

1-Started with a radiator flush using just distilled water.
2- Oil change + filter
3-Replaced poly-belt
4-Replaced spark plugs (apx 10+ years old!!)
5-Replaced both side – distributor caps and rotors (apx 15 years old!)
6-Replaced both accumulators
7-Found and repaired ohmic connection to Aux Fans . . . no low speed
8-Replaced windshield washer fill tube and grommet
9-Replaced all four tires . . . 12 years old set

And here’s what it looks like today . . . still in the garage . . temp is 95F!
2608907
 

·
Premium Member
M120, M119, W126*2 + Silver Avantgarde wagon
Joined
·
4,673 Posts
Full synthetic oil change and filter; new 100 Amp battery; new front brake pads... all on the M120.

She flies.
 

·
Registered
Vogon constructor fleet.
Joined
·
9,208 Posts
On my '94 S500, plugs, wires, ignition coils (MUCH easier to do if you take the left headlight off the car), distributor caps and rotors. The car only has 134K on it but, as far as I can tell, the coils and wires were original. Mileage notwithstanding, they're STILL 25 years old so it was time for a redo.

Tomorrow a fresh oil change, a full detail then into storage until Spring. She and my '95 SL320 have never seen a single snowflake and, as long as I hold the titles, never will.
 

·
Registered
Joined
·
31 Posts
I ‘ve driven my ’94 S500 cpe for 20 years . . . and it’s now 25 yrs old. It’s been the most reliable Mercedes that I’ve ever owned with maintenance costs being minimal. After I retired, it has spent a lot of time in the garage for lack of driving.

So it was time to give it some love . . . as this thread says.

1-Started with a radiator flush using just distilled water.
2- Oil change + filter
3-Replaced poly-belt
4-Replaced spark plugs (apx 10+ years old!!)
5-Replaced both side – distributor caps and rotors (apx 15 years old!)
6-Replaced both accumulators
7-Found and repaired ohmic connection to Aux Fans . . . no low speed
8-Replaced windshield washer fill tube and grommet
9-Replaced all four tires . . . 12 years old set

And here’s what it looks like today . . . still in the garage . . temp is 95F!
View attachment 2608907
Looks really GOOD,gotta treat these cars right and they'll treat us right...
 

·
Registered
Joined
·
31 Posts
I have a 96 S420 with over 202,000 miles,I'm gonna have all (4) BILSTEIN B4 OE REPLACEMENTS shocks installed and a pair of brand new rear springs installed tomorrow at an independent Mercedes Benz shop I've been dealing with....
 
2021 - 2040 of 2053 Posts
Top