Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
2008 E350 4M, 1988 300TE
Joined
·
5,432 Posts
Discussion Starter #1
rant start/
Trying to figure out why my FL speaker is getting static and cutting out...

First time I've had this out. Headunit was installed by bestbuy before I started doing all the work myself.

Trying to figure out what the hell they did is like learning Chinese. Why they needed to chop the OE harness, install another harness then wire to MB wiring is beyond me...:confused::confused:
On my 87 I literally used 4 OE wires and rest were just directly to speaker. I don't understand...

/rant end


-------------

anyway!!!

What is this connector? It wasn't bestbuy as it has an MB logo on it. Can't figure it out...

 

·
Registered
89 300E; 00 E320
Joined
·
2,511 Posts
Brown / Blue looks like anti-theft stuff

Anti-Theft Alarm System 163-5

X6 Terminal block, terminal 58d (2-pole) Center of dashboard, below radio 240-3

X6........Terminal block (terminal 58d) (2-pole)............................................. ................................B.1/10......47
 

·
Registered
95 E320 Kombi Sportline+ suspension, 94 E420 Sportline+ suspension, AMG Gen II
Joined
·
45 Posts
Connect it to chassis of radio (ground) so when it is removed, factory alarm will go off, if it hasn't already....
 

·
Registered
2008 E350 4M, 1988 300TE
Joined
·
5,432 Posts
Discussion Starter #4
Thanks guys great find
So it just needs to be attached to the ground wire or just to the body of the headunit?

So either bestbuy didn't know what it was, or I accidentally pulled it off when I removed maybe...
 

·
Registered
95 E320 Kombi Sportline+ suspension, 94 E420 Sportline+ suspension, AMG Gen II
Joined
·
45 Posts
There is a male tab on back of factory radio that the female part of plug connects to.

Make a one inch wire jumper with a ring spade terminal on one side to connect to back of new radio and put a male tab spade on other end and plug into factory plug. Make sure its not too tight.
 

·
Registered
2008 E350 4M, 1988 300TE
Joined
·
5,432 Posts
Discussion Starter #6
Maybe that is why my alarm goes off randomly? Any chance?
 
1 - 7 of 7 Posts
Top