Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
2009 ML320 Bluetec, 2013 Tesla Model S 85
Joined
·
875 Posts
Discussion Starter #1
Generic scan tool says P2201 is NOx sensor values out of range. Searching this site associates it with transmission troubles in 2002 ML. Anyone seen it before?

Appointment at dealer first thing in the morning.
 

·
Registered
2009 ML320 Bluetec, 2013 Tesla Model S 85
Joined
·
875 Posts
Discussion Starter #2
Generic scan tool says P2201 is NOx sensor values out of range. Searching this site associates it with transmission troubles in 2002 ML. Anyone seen it before?

Appointment at dealer first thing in the morning.
NOx sensor replaced.
 

·
Registered
2009 ML320 Bluetec, 2013 Tesla Model S 85
Joined
·
875 Posts
Discussion Starter #3
Interesting thing about the replacement is that apparently they ran my ML at idle for an hour after. Or at least thats what the "From Start" trip meter says.
 

·
Registered
2008 C230 4MATIC; 2008 ML320 CDI 4MATIC
Joined
·
819 Posts
Interesting thing about the replacement is that apparently they ran my ML at idle for an hour after. Or at least thats what the "From Start" trip meter says.
:D Maybe they just took it for an 'extended test drive'... :eek:
 

·
Registered
2009 ML320 Bluetec, 2013 Tesla Model S 85
Joined
·
875 Posts
Discussion Starter #5
A very slow extended test drive because the From Start tripmeter said 5 MPH average for 5 miles in 1:05 H.

I guess it had to idle for at least 45 minutes to get the average down to 5 MPH.

Didn't note the From Reset values before leaving it with the dealer.
 
1 - 5 of 5 Posts
Top