Mercedes-Benz Forum banner

441 - 447 of 447 Posts

·
Registered
1987 560SL (L.Tonk) [92,700 miles]
Joined
·
350 Posts
Was away for 2 weeks and tried to start Tonk up but no crank. Been on the trickle charger for 2.5 days and still showing “Charging”. It started fine today but I suspect a new vampire load to investigate. I’ll add it to the list of other things I won’t be getting to anytime soon.


Sent from my iPhone using Tapatalk
 

·
Registered
1986 560SL, 1993 Isuzu Bighorn (RHD & Diesel)
Joined
·
38 Posts
After two trips to radio shack and one trip to hobby lobby I had everything needed to fix my coolant light, clock, and paint my speedo needles. Also spend the day searching down vacuum leaks, turns out I had a few cracked lines, cracked rubber connectors, and a cracked air intake manifold boot. Do y'all think I should replace the air intake manifold gaskets and the round rubber gaskets while I'm kind of in the area? I really don't want to go that deep but if it's worth it then I might as well

2643840
 

·
Outstanding Contributor , Bob's Your Uncle!
-----'83 280 SL----- 5 speed....The PIG
Joined
·
29,605 Posts
What did I do to my 107 today.....hmm.....I actually talked about it with a friend.
Does that count?
 

·
Registered
'72 450SL, 107.044-12-000422
Joined
·
282 Posts
Took it for a 4-hour round trip to the defunct community of Budapest, GA. Nothing left there but a cemetery. Perfect drive on nothing but country roads and nothing broke.
I love working on the car but when it’s running right, there’s nothing better.




Sent from my iPhone using Tapatalk
 

·
Premium Member
1976 450SL
Joined
·
516 Posts
First 'drive' today! :) I took it down the driveway and back (probably around 600') - longest trip the car has done in at least 20 years....everything seemed good, with no unexpected noises, and I think it even shifted.

This was after spending the morning setting ignition timing and idle air adjustment. Still not perfect, but it's running a lot better, and idles around 700 - and the smoke seems to have subsided a lot.

I do seem to have a transmission fluid leak from the front of the box, which for some reason seems to be worse when the car is parked on a slope facing uphill (seems odd), but I've done nothing to the transmission yet (other than change the bushes in the shift linkages) - want to see how it is on the road before deciding what to do (I have a spare).

2644797
 

·
Registered
1986 560SL, 1993 Isuzu Bighorn (RHD & Diesel)
Joined
·
38 Posts
Replacing the intake manifold gasket so I figured I might as well clean things up a little. Used some purple power and a brush followed up by a hot pressure washing.
2644802

2644803
 
441 - 447 of 447 Posts
Top