Mercedes-Benz Forum banner

541 - 560 of 580 Posts

·
Registered
1997 E420; 2008 C300 Sport
Joined
·
20 Posts
1999 E320 and 2003 E320T
Thought so. Mine is a '97 so I don't have some of the newer tech. No electronic key (only unlock and lock fob) no steering wheel controls, and I have the outdated homelink visor that blinks red, not amber. As far as I know, '98 introduced the electronic key and the newer homelink with rolling code support.

Sent from my SM-G965U using Tapatalk
 

·
Registered
2001 E320 Brilliant Silver/Charcoal 2002 E320 Special Edition
Joined
·
284 Posts
I changed the oil on my 2001 yesterday. I used Motul 8100 Xcess 5w40. I also added two cans of Liqui Moly oil saver to slow down a rear crank shaft seal leak. Mileage is 102,668.
 

·
Registered
Green '02 E320 Wagon
Joined
·
570 Posts
Think it will buff out?

IMG_20191009_152959.jpg

I clipped a little curb at 55 mph while swerving to make an exit that I almost missed. It cracked that portion of the wheel and put a slight bulge into the tire. The tire still held air and drove smoothly until I found a place to pull over and swap on the spare.

Thankfully there are plenty of W210s in junkyards. I am in NJ six hours from home in NH. Still, I used and found three donors on the east edge of the state near where I am. Tomorrow, I'll have my choice of used wheel and will get the tire swapped on to it.

Heck, I might even get a second wheel to replace one of mine where the coating is bubbling up and cracking away. Why couldn't I have cracked that ugly one.
 

·
Registered
94 E320 5 spd conversion
Joined
·
930 Posts
Swapped cars with mom. Her's now has new tires (Tire Rack/ASAP at the house, great service), engine and trans mounts, plugs, and front sway bar links. Also inspected front spring perches, they are like new. Not the same for the springs...both have small piece broken on bottom. New ones are on the way.
 

·
Registered
Joined
·
1 Posts
Changed sparkplugs all 12, got an E280 4matic Avantgarde 2000 (facelift, with stickers on driver door from stutgard), probably "weak" on the US guys here since the 320 was the "smallest" sold in the US. I love the car, Bought it in 2016 of off my parents who is the only owner since it was new in 1999 but it is a 2k facelift model, makes little sense production year/model year.... they should get a standard for that... anyway as mentioned changed all spark plugs and all spark plug wires and 2 coils that showed misfire in diagnostics. Changed oil ofc, mobile 5w--30. Changed serpentine belt and idle pulley. Waiting for new bearing and casing for the autotenaioner. Also going to change auto tranny oil, got the oil and a friend hooked me up with a lift in couple of weeks that I can use over a weekend. I always end up writing long letter like posts, hope you bear with me, and also about the "US" market thing there was no offense or anything like that from my side just stating that this is my dream "kinda vintage" car, for sure I wouldent mind having an e 430 instead... so yeah.
2607741

Got 190k Km on it so it should have a lot left with some TLC, luckily it's almost completely rust free due to tectyle since day 1 and sandblasting and rustprimer + tectyle inbeetween when needed.

Best wishes
John
 

·
Registered
2001 E320 RWD- 2011 E350 4M
Joined
·
574 Posts
Finally got a new Pioneer head unit from Crutchfield and also got the wiring harness for the steering wheel controls. Oh my, what a difference and I didn’t even touch any speakers. Bluetooth is so nice and the installation was a breeze, didn’t cut or splice any wires, I was done less than 10 minutes.
Putting the snow tires back on this Tuesday.
 

·
Registered
93 190E 2.3, 94 E320 (sold), 01 E320, 99 S320, 18 Durango
Joined
·
4,977 Posts
Installed a leather steering cover from Amazon. Took about 60 mins to install but much better than the worn wheel.
I installed it before on my W201 and W140 and like it so much. Will see how it holds up over time. Also added more photos for my W140 with different pattern stitches.
2609885
2609886
2609887
2609888
2609889
2609890
2609891
2609892
2609893
 

·
Registered
'95 S500 (sold), '97 E420
Joined
·
249 Posts
Passenger window regulator broke yesterday morning. What a cheezy pos. The arm came un welded from the gear. Was only 3 tiny spot welds, and one of them never was stuck. Made of stamped thin sheetmetal.
So, today, I set about the task of repairing it. got it out, welded the arm back on, and installed it. works fine for now. Then hadda glue the plastic parts back on the door panel so it would snap back on. And while I was there, got the seat switch working. (for now) All in all a good day. :D
 

·
Registered
1998 W210 E280
Joined
·
176 Posts
Replaced my transmission control module, super smooth shifts now. Today Im busy lifting front passenger side mat, phones a small damn of water, probably due to all the damn leaves gunked up under the hood behind the modules and under the wiper. Sanding the floor now, applying rust preventer and waiting for thefaom that is moulded underneath the seat to dry out.
 

·
Registered
1997 E420, 1999 E320 4MATIC, 1999 SL500
Joined
·
624 Posts
The '97 E420 started misfiring on #8. I priced out all the parts for a tune up - coils, plugs, connectors - and it comes to $530. I told myself that's not happening, so I bought one coil and replaced the one on #8. The car is back to purring like a kitten. I saw some corrosion on the connector so I cleaned it up a bit before I put it back in. I don't have the tune up history on the car, but it looks like it could benefit from all new ignition parts. For now though, it is back on the road.
 

·
Registered
1996 SL500, 2000 E430
Joined
·
3,668 Posts
I am planning on a cross country trip in the next week - will put 5,000-9,000 miles on in a few weeks. While my idler pulley bearing was fine at 100,000 miles (and original since new) I thought it might be smart to preemptively change it.

Imagine that going on the road - with towing, motels, finding a shop...

Anyway when I got the car I had changed the belt and had ordered the 2 tools you need to remove the fan blades.

2612347
In the interim some time ago I had apparently thrown out the 36mm wrench at some point.

Because, you know, I had to wonder "who needs a 36mm open end wrench?"

Well, I did apparently.

Ordered another from Amazon (thanks Prime and 1 day delivery).

Got the new one on.

Old one seemed fine but my shop friend said with those plastic housings they can be good one day - gone the next.

Did not want it going 2,000 miles from home.
 

·
W210 Moderator
99 E320
Joined
·
5,041 Posts
Discussion Starter #556
Stunned to learn that the last time I refueled was in Nov 2018. So I washed the car, gassed it up, threw in a bottle of fuel injector cleaner I had, and drove 120 miles to stretch its legs. 67,900 mi
 

·
Registered
1999 E320, 2003 E320 Wagon, 2005 C230K SS, 2010 Accord LX w Eibach & Koni FSD's
Joined
·
2,653 Posts
Stunned to learn that the last time I refueled was in Nov 2018. So I washed the car, gassed it up, threw in a bottle of fuel injector cleaner I had, and drove 120 miles to stretch its legs. 67,900 mi
I hardly drive my W203 anymore since getting my W210T. Last time I filled up the gas tank, I added Stabil to it. Suppose to extend the life of fresh gas up to two years.
 

·
Registered
Green '02 E320 Wagon
Joined
·
570 Posts
Stunned to learn that the last time I refueled was in Nov 2018.
When my car sit for a year, it's because of all the problems keeping it off the road. That's why I have two. But I've learned the hard way not to have a car sit for a year... outside. Yup, no garage. Break calipers get frozen in place, fluid lines rot and leak, tires dry rot. I'm really trying to get both of my cars in good shape so they can both be in rotation.
 

·
Registered
'95 S500 (sold), '97 E420
Joined
·
249 Posts
I drive mine regularly. Not daily, but weekends, and whatnot. Yesterday, I hadda go to the "U-Pullit" for some wiper arms for Th' Ol' Ladys car. While I was there I found that there were several 2nd gen 210s. So, I grabbed an amplifier. Mine works on the rear, and squeals on the front. I got them swapped out, and the "new" one works good on the front, with nothing on the rear. :rolleyes: But, I get to listen to the radio without the squeals. ;) I'll tear into the old one, and re- cap it, mabe that will do it.
 

·
Registered
1996 SL500, 2000 E430
Joined
·
3,668 Posts
Just got back from a 4,392 12 day trip though the Southwest - AZ, NM, TX.
 
541 - 560 of 580 Posts
Top