Mercedes-Benz Forum banner

21 - 40 of 7015 Posts

·
Premium Member
'95 SL 500
Joined
·
215 Posts
$9.20 at parts.com and took me 20 minutes to replace. Mine was broke when I got it too. A piece of it was still in the armrest. Uge a screwdriver if you need to slide it back.

Have to clean carpet today and prepare to re-glue vinyl interior trim in the hardtop. Hope I can figure out how to take the trim pieces off.


My daily chore is diagnosing my high idle problem....
Along with that, I wiped off the sprinkler water spots.:crybaby2:

Fiddled with my sliding arm rest that is stuck forward. ( The darn button is missing!)
Doing some fun TLC in the interior.... previous owner wasn't as detailed as me.

Just bought it 2 weeks ago!
 

·
Registered
'93 SL500 (sold), '88 GMC Sierra 360,000 miles, '86 Yamaha FJ1200 (criminally fast)
Joined
·
770 Posts
$9.20 at parts.com and took me 20 minutes to replace. Mine was broke when I got it too. A piece of it was still in the armrest. Uge a screwdriver if you need to slide it back.

Have to clean carpet today and prepare to re-glue vinyl interior trim in the hardtop. Hope I can figure out how to take the trim pieces off.
I have to do the same thing...... The vinyl trim is pulling away around the triangle window on the hard top.

( Taking trim pieces off)...... patience!!!!! ( & keep hands clean)
 

·
Registered
94 SL 500
Joined
·
26 Posts
Just watching it sit in the garage while I wash my truck. Instrument cluster is out of it right now being repaired and am waiting for its return next week. Haven't driven it much in the last two weeks because of the lack of being able to know what is going on in the engine without the cluster...besides trying to guess how fast I am going without the speedometer. Wife did hook-up our GPS a few days ago to it and pointed out I only going 95 down the freeway....man, I thought I was only going 55mph. I think something is wrong with the GPS!!!

Stan 94 SL500
 

·
Premium Member
'95 SL 500
Joined
·
215 Posts
Just watching it sit in the garage while I wash my truck. Instrument cluster is out of it right now being repaired and am waiting for its return next week. Haven't driven it much in the last two weeks because of the lack of being able to know what is going on in the engine without the cluster...besides trying to guess how fast I am going without the speedometer. Wife did hook-up our GPS a few days ago to it and pointed out I only going 95 down the freeway....man, I thought I was only going 55mph. I think something is wrong with the GPS!!!

Stan 94 SL500
You drive without the cluster? wow! I don't even like driving if i forget the face to the radio.
 

·
Registered
94 SL 500
Joined
·
26 Posts
I got desperate after not driving it for a week so we took it to dinner. It is a very weird feeling not having the cluster there, especially when I started thinking when I had filled the gas tank last!
 

·
Registered
Sold1990 500sl - 1992 300sl 1999 sl 500
Joined
·
1,545 Posts
Changed the oil and filter on the 90 :thumbsup: used a pump to suck out through the dipstick after reading the posts here,soooooooooo easy, such good advice here :bowdown:
 

·
Registered
1994 SL500 with 187,000 miles on it, 2007 E350 with 250,000 on the car and 700,000 miles on engine
Joined
·
34 Posts
I put a new mass air flow meter in. Wow! What a change in performance!
 

·
Registered
1992 300sl
Joined
·
159 Posts
In the last week we had some 25 inches of rain in Atlanta with 100 year flood levels. Not a good environment for a roadster.

Then, on Sunday, we had the prettiest day one can imagine. I went out for a nice 25 mile drive through the hills of north Georgia around Lake Lanier where I live. Shear heaven.

Also took out the 61 Chrysler to spin the tires a bit with nearly 500 lbft of good old fashioned V8 torque.
 

·
Premium Member
'95 SL 500
Joined
·
215 Posts
I have to do the same thing...... The vinyl trim is pulling away around the triangle window on the hard top.

( Taking trim pieces off)...... patience!!!!! ( & keep hands clean)

Have you taken yours apart yet? I'm interested in where the clips are hiding.
 

·
Registered
'93 SL500 (sold), '88 GMC Sierra 360,000 miles, '86 Yamaha FJ1200 (criminally fast)
Joined
·
770 Posts
Have you taken yours apart yet? I'm interested in where the clips are hiding.
Not yet...... I'm going to get a repair manual to guide me. and the vinyl trim is low priority for the moment.... on the car.

But I'll let you know when I work on it.
 

·
Registered
Mercedes Benz S350(2003) - 600SL(1993)
Joined
·
160 Posts
I did lot of work in my 600SL
1- i changed all the fuses.
2- i cleaned the air mass flow
3- i changed the ENG oil + filter
4- i changed the Transmission oil +filter
5- i changed the suspension with all the joint in the front & the arm supports ( remove
the hyd suspension & install W124 E500 suspension)
6- i changed the spark plug ( pouch 4 heads )
7- i changed the radaitor & the temp volve
8- ENG/Transmission Mount
9- Eng hood pad.
 

·
Registered
'96 SL500, Triple Black
Joined
·
1,650 Posts
-watched it snow ... grrrr ... then,
-cleaned cabin air filter and compartment
-wired a line to the front tow hook cover plate, just in case I hit a curb :D
-cleaned more of the engine bay

... I guess now I will read about sucking the oil out through the dipstick. That sounds crazy, but off I go. And I need to work on some paint swirls.
 

·
Premium Member
'95 SL 500
Joined
·
215 Posts
Changed out lugs and tried to find out why console and door pockets dont lock. Not like i need it but since it should, it will have to be fixed.
 

·
Registered
'96 SL500, Triple Black
Joined
·
1,650 Posts
Solved the flashing dash problem.
WooHoo!
:p
Was this from a faulty ground? What fixed it, not having the problem just curious.

Your color combo rocks! Do you have a pic of the interior like with door open to see it better?

I have to sign on each day just to check out your avatar :bowdown:

Sorry for hijacking the thread...
so I will add to it ...
-removed seat bottom to find rattle (metal pen stuck in seat pan),
-removed faceplate from OE Alpine radio for loose radio buttons - waiting for new faceplate in mail.
-vacuumed under seats - found enough for lunch off the dollar menu.
 

·
Registered
'93 SL500 (sold), '88 GMC Sierra 360,000 miles, '86 Yamaha FJ1200 (criminally fast)
Joined
·
770 Posts
After owning this S L for only 3 weeks, I finally removed the hard top. A nice day on the coast to have the top down!

I saw the top open/close & looked quickly, before buying, but yesterday I really got a chance to inspect it.

All the action of opening/closing is perfect!

WOW!! It's in great shape! All original, and not a stitch out, no tears, no discoloration!

I cleaned the windows, and it cleared up fairly easy! Need to try some polishing tricks, but they are very clear!

I only want to carefully clean the underside which shows some "storage marks", but the liner is good too!

Up-date.... The dark/chrome metal frame along the edge of the soft top cover has quite a black mark around it... from the rubber seal. It doesn't want to polish out. Any tricks?
 

Attachments

·
Premium Member
'95 SL 500
Joined
·
215 Posts

Attachments

21 - 40 of 7015 Posts
Top