Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My 99 SLK 230 has been making a weird whirring sound over the past few months. It used to be just when it first starts, and now while that's still when it's at its worst, it persists whenever I drive it. It shifts hard for the first few minutes, doesn't like to change gears, and while going slowly I feel a huge drop as soon as I take my foot off the accelerator, almost like I slammed the brake. The whirring increases in noise and pitch as I push the accelerator. After the first few minutes, it warms up, and is somewhat better, but not much. The car seems like it works really hard to go uphill, but always makes it without a problem besides feeling like it's working hard and it making a lot of noise. The whirring used to stop after the car warmed up, but now the sound and the feeling are there whenever the car is in gear. I first took it in to a dealer, and they said it was the supercharger. I took it to get a second opinion and the guy said it wasn't the supercharger, it was the exhaust system, but that it wouldn't cause much of a problem with performance, and was mostly just an annoyance. That was about a month and a half ago, and it has since gotten steadily worse and it certainly affects performance. It makes this pleasurable car a pain to drive. Any thoughts would be much appreciated!
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks, Manic. I checked through that, and it sounds more like a rattle there, whereas mine is more of a whir. I listened to the youtube video, and that's definitely a lot more battering around than mine sounds like. But it's interesting that they thought it might be the tranny, and that was my initial inclination too, though I don't really trust my inclination. I appreciate the link in any case.
 

·
Registered
Joined
·
351 Posts
the rear differential tends to leak on the SLK, and excessive oil loss there can explain your noise/preformance issues. Also check the transmission fluid level.
 

·
Registered
Joined
·
377 Posts
It used to be just when it first starts,
Cold start only?......?? not 'hot start'

Sounds like the Supercharger (or belt tensioner bearing) to me.......but depends on version & location of SLK (US models use S/C for air injection on cold start)

Welcome.......... and please update your User Profile with location and include your SLK details there for future reference

David
 
1 - 5 of 5 Posts
Top