Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello all

So i have a 2010 Mercedes S550. As of recently, the climate control function seems to be out of wack. Component buttons all appear to be functioning properly on the command screen, only i have come to realize that more and more of the functions are no longer actually functioning. The on off button looks like its turning on a off, but in fact it does nothing. The blower is on at all times, the only difference it makes to have it turned "on" is that the heat starts working, but none of the vents are focusing the air based on the controls. Higher or lower air pressure buttons dont actually make the air come out higher or lower. When the vehicle is switched off completely, the blower turns off for a few seconds but even though the entire component is off it ends up blowing cold air intermittently and turning back off on its own. I come back to the car hours later only to realize all the windows are foggy from the air being on constantly. HELP!!!!
 

·
Registered
2011 S550
Joined
·
18 Posts
Have you tried resetting the ac system? I believe you hold the air recirculating button and the defroster button for about 10 seconds to reset the ac computer. Lights should flash after it resets.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I have tried resetting the system, but it does not look like it resets. its the recirculating button and the front defroster symbol, for 10 seconds while vehicle is on?
 

·
Premium Member
2006 S55 AMG - 2007 SL55 AMG P030 -2007 S65 AMG
Joined
·
247 Posts
I have tried resetting the system, but it does not look like it resets. its the recirculating button and the front defroster symbol, for 10 seconds while vehicle is on?
Replace the HVAC voltage regulator (located inside the fan housing) the part is about $50 and if you replce the fan as well $200 takes 1-2 hour or less if your handy
 
1 - 4 of 4 Posts
Top