Mercedes-Benz Forum banner
1 - 8 of 8 Posts

·
Registered
1999 Mercedes E300 td auto
Joined
·
23 Posts
Discussion Starter · #1 ·
hi,ive been searching for a solution but not found anything relating to a little problem that has just developed on my 99/e300td..recently i noticed the drivers courtesy light doesnt operate when you get in car,the rear and all other lights operate ok when i open door,and also im not sure if its related but the remote locking has been playing up also,couple of mornings i had to open door with key setting alarm off.i have to go right up to door handle and point at infrared to get it to work.
ps the light does still work if you push button but doesnt work when you opens doors!!
i hope someone can give me some sort of help or insight as to what the cause may.thanx
 

·
Premium Member
2001 E320 - Brilliant Silver/Ash: 107,000+
Joined
·
17,193 Posts
Not to nit pick but the car in your profile is not the same as the one in your thread. Do you have a 300TD or a 230TD? Not that it matters much, I'm just being neurotic tonight.

These keys have a short range especially when the batteries get weak so I would change those to see if it helps. You can also try cleaning the IR window on the key and the door handle sensor.

The courtesy light is the one in the upper console? If so I don't know what to tell you about that.
 

·
W210 Moderator
99 E320
Joined
·
5,337 Posts
(if I'm understanding your situation correctly)
check your owner's manual in respect to Interior Lighting. for my 99 E320 USA
issue, i press the light switch for the driver's side once, to activate the courtesy
lamp when opening the door.
 

·
Registered
1999 Mercedes E300 td auto
Joined
·
23 Posts
Discussion Starter · #4 ·
Not to nit pick but the car in your profile is not the same as the one in your thread. Do you have a 300TD or a 230TD? Not that it matters much, I'm just being neurotic tonight.

These keys have a short range especially when the batteries get weak so I would change those to see if it helps. You can also try cleaning the IR window on the key and the door handle sensor.

The courtesy light is the one in the upper console? If so I don't know what to tell you about that.
hi musikmann,yes that is my car in profile,its a 99/e300td.my remote has new batteries and the spare remote also works also but only when you basicly aim it at door,the problem must be related to front courtesy light somehow as the problem happened at same time!!
 

·
Registered
1999 Mercedes E300 td auto
Joined
·
23 Posts
Discussion Starter · #5 ·
hi raymond,thanx for reply..like i explained in my thread the problem seems to be related to alarm remote problem as it seems to have happened around the same time,i used to be able to operate remote from a distance and now i have to aim remote at door handle.
 

·
Registered
1999 E300 Turbodiesel
Joined
·
463 Posts
Sounds like you have two dependent issues----the lamps and the central locking system.

The lamp------I would check the door switches that are located in the pillars.

The central locking system, can be much more complicated because two or more systems are involved, however you have confirmed that the remote key has new batteries, that leaves any other elements that are in the central locking system with a fault----which one is faulty---one of the front door receivers, one of the front door control modules, the PSE unit or the over head control module.

You can "OL" the issue and start changing out individual parts untill you find the culprit or you can spend the bucks and get the body codes read. That way you will know what module is faulty and then you yourself can replace the part.----or start guessing!!

Good luck
 

·
Registered
1999 Mercedes E300 td auto
Joined
·
23 Posts
Discussion Starter · #7 ·
well problem solved,spent abit of time replacing every fuse under the rear seat and ran some thin abrasive paper down where fuses sit,where the central locking system is and alarm module i checked everything seemed ok,i did notice that 1 of the thin wires that went to alarm module was trapped under trim.put everything back together and bobs your uncle,dome light in front was on and alarm remote arms alarm from distance.so basicly it was related,dome light and remote issue.
 

·
Premium Member
2001 E320 - Brilliant Silver/Ash: 107,000+
Joined
·
17,193 Posts
Bloody Hell, congratulations mate!
 
1 - 8 of 8 Posts
Top