Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Mercedes C-Class 270 CDI 2005
Joined
·
3 Posts
Discussion Starter #1
first of all Hello Everyone I am new to this forum and I have to say this place is full of great people who likes to help others and this is great.

Looks like i have same problem as some of You. Few days ago i did fuel up my car with 40l of normal diesel,,,, just after i started engine diagnostics indicator lamp went on and it stays on and on and on. I do lost some power looks like kick down doesnt react at all. Many of you suggested that MAF is the source of problem. I will clean it in next few days hope will help.. if that will not work i will get the codes from computer post them on forum and i would be very happy if anyone could help me to sort out the problem. :bowdown:
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
Welcome to Benzworld. Please complete your profile as this will help members give you the most accurate answer to your questions. Location is also important when we need to help you find parts etc. This forum is for introductions only and all questions should be posted on the appropriate sub forum for your car.

At the bottom of the page you will find forum jump, click on this and view all the available sub forums.

For FAQ see the Benzworld help section here:
BenzWorld Help - Benzworld.org - Mercedes-Benz Discussion Forum

Regards
 

·
Registered
Mercedes C-Class 270 CDI 2005
Joined
·
3 Posts
Discussion Starter #3
Hi Eric.
Thanx for the advice.
I'll make sure that in future i will post questions on appropriate forum.
 
1 - 3 of 3 Posts
Top