Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
1996 C280 W202
Joined
·
9 Posts
Discussion Starter #1
Hi all,

So I have an issue with my 1996 c280 w202. When I start it up it likes to stall out on me after about 10 seconds or so. To prevent it from stalling I need to keep my foot on the gas to get the Rps up to about 1-1500. It dosent do this every single time but 9/10 times it will. The car has been driven with this issue for years at this point and would just like to get to the bottom of it, it’s a big annoyance. These are things I’ve replaced therefore ruled out to be the issue :

Vacuum leak
Fuel filter
Air filter
Mass airflow sensor
Cabin air filter
Air intake temp sensor
Spark plugs
Coils

I have a replacement knock sensor I was going to put it in but figured it would be unlikely. Even my local specialty European shop had no idea at this point as I don’t have a check engine code. I was told it may be the throttle body or throttle body controller module of some sort but was hoping not as that’s a more expensive repair. Does anybody have any ideas? It would be greatly appreciated!
 

·
Registered
1996 C220 2007 ML320 CDI
Joined
·
1,830 Posts
Check for degrading wiring insulation on the engine harness. That could be one thing. The next thing is the throttle body. If you have the original throttle body, I promise you the wires on the inside are completely disintegrated. Unfortunately you can't see those wires without cutting the outer insulation off first (only a small section to check the condition of the wires inside). The idle is electronically controlled via those wires, so if they're shorting out against each other then the computer has no idea what to do to keep the engine running.
 

·
Registered
1997 C280 Elegance
Joined
·
6 Posts
I have a similar (or possibly the same) issue with my '97 c280. Every once in a while, when I shift from park to drive, the car will stall. I find that if I am able to rev the engine slightly when I shift into drive it will not stall, but this doesn't help if I am parked in a spot where I dont have tje opportunity it to go forward! I end up needing to either let the car idle for five minutes or more in order to shift out of park without stalling.
If it is the throttle body, does anyone have a part number for replacement?
 

·
W163 and General M Gremlin
Joined
·
3,693 Posts
I have a similar (or possibly the same) issue with my '97 c280. Every once in a while, when I shift from park to drive, the car will stall. I find that if I am able to rev the engine slightly when I shift into drive it will not stall, but this doesn't help if I am parked in a spot where I dont have tje opportunity it to go forward! I end up needing to either let the car idle for five minutes or more in order to shift out of park without stalling.
If it is the throttle body, does anyone have a part number for replacement?
Look here
 
1 - 4 of 4 Posts
Top