Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello all,
Lately I have a strange kind of electrical fault with my car, and i couldn't find a relevant solution in the sticky. I will try to explain the problem, the best I can and hopefully, pros in this forum can help me out!!

Here it goes:

Car Model: C-Class W202 93-97 Model (Elegance Trim)
NOTE: The comfort controller unit is in the boot behind the batteries along with the spare wheels!!

> The problem is related to SRS warning light and electric windows from my point of view.
> The strange bit is the system is bit slow to switch on!!
> Normally when you turn the ignition to start position you get all the lights including SRS should come up and go off once the engine is started, anyways that's my concept.
> BUT NOW IT DOESN'T!!! The ABS light comes on and goes off once the engine is started but NO SRS LIGHT.
> NOW for the interesting part. Once the engine is started and the car is running, like after 2-4 min (It varies and sometimes never!!) the SRS lamp comes on goes off after few seconds :confused:
> NOW for the biggy, As long as this SRS lamp doesn't show-up, none of the electrical windows work!! :crybaby2:

> More on the electrical windows .... The electrical windows won't work unless the SRS light comes on and then goes off. So there are times when I can't operate the windows at all.

> The ONLY SOLUTION TO WINDOWS PROBLEM is to open either of the front doors and the operate the switches and then every windows work, CLOSE THE DOORS and nothing works :surrender:

Hope you all who read it had fun on my expense :D BUt I would seriously be grateful if any one could help me with a solution and isolate the system responsible for this headache without me ending up with a hole in the pocket :rolleyes:

Thanks for reading through....
 

·
Banned
Joined
·
3,373 Posts
You did not specify the year model, engine size, etc..

Let's start by decoding the VIN.. Post up your VIN and let's see which features were fitted on the particular car.. This can be very helpful to track down your issue..
 

·
Registered
Joined
·
170 Posts
> The ONLY SOLUTION TO WINDOWS PROBLEM is to open either of the front doors and the operate the switches and then every windows work, CLOSE THE DOORS and nothing works :surrender:
Just a note to tell you that this is standard behavior for a w202 (or any other Benz I had) when the ignition is OFF.

You can operate the windows (or sunroof) whenever:
- The ignition is on
- OR one of the front doors is open

One might conclude that your 'window control module' (if such a beast exists) doesn't get power from the ignition lock...
 
1 - 3 of 3 Posts
Top