Mercedes-Benz Forum banner

41 - 51 of 51 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #41
You need to initialize steering angle sensor for yellow three finger salute to disappear. Turn wheel lock to lock few times.
Thank you so much!!! Do I turn off the car for the lights to reset?! I'm so nervous
You need to initialize steering angle sensor for yellow three finger salute to disappear. Turn wheel lock to lock few times.
You need to initialize steering angle sensor for yellow three finger salute to disappear. Turn wheel lock to lock few times.
Alright I drove it around and it starts beeping non stop while I'm moving I turned the car off after coming to a stop and steering from left to right a few times. Turned it back on and the same 4 lights are on
 

·
Registered
2003 C320 coupe, 2000 ML320
Joined
·
516 Posts
Very carefully, open the hood, pop the lid off the fuse box.. and jiggle around all the wires and connectors.. Tap on top of all the relays.. You might have a broken wire right at the connectors.. Wires can break inside the vinyl covering so looks like it's good, but if you pull on them, they feel soft and stretchy...

Ps.. don't worry about the lights right now, ..that doesn't have anything to do with why the car wouldn't start..
 

·
Registered
Joined
·
25 Posts
Discussion Starter #43
Very carefully, open the hood, pop the lid off the fuse box.. and jiggle around all the wires and connectors.. Tap on top of all the relays.. You might have a broken wire right at the connectors.. Wires can break inside the vinyl covering so looks like it's good, but if you pull on them, they feel soft and stretchy...
Okay wish me luck! Let's hope she doesnt decide to not start again!
 

·
Registered
Joined
·
25 Posts
Discussion Starter #44
Okay wish me luck! Let's hope she doesnt decide to not start again!
Alright so I forgot to let you guys know but yesterday I did the whole process again and made sure everything was plugged in and the same 4 lights are on still. I'm going to check today if the merc still turns on or not. So far it's the 4 lights and constant beeping while moving, along with the inability to turn the traction control on or off. I haven't noticed anything else but I'm scared to drive the car with all those lights on, I'm not sure if it is safe. Let me know about any other suggestions, thanks!
 

·
Registered
2003 ml500, 2004 ml350
Joined
·
575 Posts
BAS-ESP
ETS
ABS
Brake

All four work together and one light can trigger the others. The steering sensor as Witek pointed out is the most common, usually after disconnect or battery replacement. You did disconnect the battery several times. when you did the reset you turned all the way right and all the way left stop to stop? With Every battery disconnect it can cause you to need to reset the steering. So if the first reset did not take then you disconnected it,and did not reset the problem is in a loop..

How old is your battery a old battery with low capacity can be the causse.

Bad brake light switch

Failed ABS sensor could do it too

ABS module

Some ot these will show up with a code reader. Heard it could put the car in limp mode, Don't know itf you got a chance to drive past 25mph.

The beeping is also part of the warning package.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #46
BAS-ESP
ETS
ABS
Brake

All four work together and one light can trigger the others. The steering sensor as Witek pointed out is the most common, usually after disconnect or battery replacement. You did disconnect the battery several times. when you did the reset you turned all the way right and all the way left stop to stop? With Every battery disconnect it can cause you to need to reset the steering. So if the first reset did not take then you disconnected it,and did not reset the problem is in a loop..

How old is your battery a old battery with low capacity can be the causse.

Bad brake light switch

Failed ABS sensor could do it too

ABS module

Some ot these will show up with a code reader. Heard it could put the car in limp mode, Don't know itf you got a chance to drive past 25mph.

The beeping is also part of the warning package.
The beeping is very annoying but it sounds like it's safe to drive? Also it's probably that loop you mentioned, because as far as I've had this car, it hasnt had any problems with sensors, other than the o2 sensors! :) I'm going to wait and see if it resets on it's own if not I'll investigate further.
 

·
Registered
2003 ml500, 2004 ml350
Joined
·
575 Posts
Just to Clarify if it is in limp mode or goes into limp mode your "Check Engine Light will come on.

All you need to do is next time before you pull out of your parking spot turn the wheel right left 3 or 4 cycles 5 if you want to be extra sure. be sure nothing is impeding the wheels like a curb. How old is the battery? Benzs are very voltage sensitive.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #48
Just to Clarify if it is in limp mode or goes into limp mode your "Check Engine Light will come on.

All you need to do is next time before you pull out of your parking spot turn the wheel right left 3 or 4 cycles 5 if you want to be extra sure. be sure nothing is impeding the wheels like a curb. How old is the battery? Benzs are very voltage sensitive.
It's not in limp mode but the check engine light will probably come on bc of the o2 sensors eventually. The car has the battery I bought it with but it hasnt given any problems as far as I'm concerned, if it was old, this problem would've happened other times I've removed the battery. This is the the first time this comes up. When I get home I'll do the cycles again. Does the car have to be in any specific position or is having it in park fine?
 

·
Registered
2003 ml500, 2004 ml350
Joined
·
575 Posts
Get ahold of an multi meter, borrow or buy one I get them free with a coupon from harbor frieght and check the battery voltage post to post. Let us know what you find.

Stop by orielley’s or auto zone or another parts store and have them read for codes now that it started some may be present.

Lastly a flatter surface like a concrete drive would be best for lock to lock.
Running in park.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #50
Get ahold of an multi meter, borrow or buy one I get them free with a coupon from harbor frieght and check the battery voltage post to post. Let us know what you find.

Stop by orielley’s or auto zone or another parts store and have them read for codes now that it started some may be present.

Lastly a flatter surface like a concrete drive would be best for lock to lock.
Running in park.
Even if I dont have a check engine light at the moment, there could still be codes? Because when I plug in my obd2 reader without the light on, it doesn't find anything.
Get ahold of an multi meter, borrow or buy one I get them free with a coupon from harbor frieght and check the battery voltage post to post. Let us know what you find.

Stop by orielley’s or auto zone or another parts store and have them read for codes now that it started some may be present.

Lastly a flatter surface like a concrete drive would be best for lock to lock.
Running in park.
Alright guys so turns out it was the 40 fuse it was in the empty slot next to where it's supposed to be! I guess while i was freaking out checking fuses I placed it in the wrong slot so the abs lights are gone!!! O2 sensors still not fixed but after these hectic days of having a car that doesnt turn on I think I'm leaving it how it is. what a scare! I'm never unscrewing that fuse panel again! Again, if it wasn't for you guys I'd probably be missing my steering wheel at this point. THANK YOU FOR YOUR HELP!
 
41 - 51 of 51 Posts
Top