Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
1983 300SD
Joined
·
396 Posts
Discussion Starter #1
Hi,

I'm not sure how exactly to ask this question, but here is my issue. With the car running (idle) there is grayish black smoke coming out through the exhaust, I guess that's how the diesels are. Anyways, I noticed that when I give some acceleration there are some black oily stuff coming out of the exhaust too and sprays all over my garage. This is only where the exhaust is located. What could be the cause?

Thanks
 

·
Registered
W108 250s '67, w123 280ce '77, w123 300d-t '85, w126 300sd '85', w140 s600 '94,w210 e230 '97, bug69
Joined
·
262 Posts
Had the same issue with my sd before, i turned out to be injection pump calibrated, all injectors were cleaned and checked if the spray was ok, after this was done the smoke turned from grayish to lighter blue color almost unseen, valves clearance was also adjusted, oil changed too, smoke is almost invisible but still smelled,
 

·
Registered
1988 300e
Joined
·
47 Posts
mercedessource.com

Check out the guy's videos on youtube. He goes by the name "mercedessource". He has a few dozen vids about repairing the old-school Benz. Really great stuff and he may have an answer for you.
 

·
Registered
1983 300SD
Joined
·
396 Posts
Discussion Starter #5
Thanks, I have seen a few of his videos before. I haven't seen any recently, but does he mention anything about the injection pump calibration?
 

·
Registered
1988 300e
Joined
·
47 Posts
There is one about adjusting the valves and cleaning the injectors that was very informative regarding those issues.
 
1 - 6 of 6 Posts
Top