Mercedes-Benz Forum banner

W124 dead

882 Views 3 Replies 3 Participants Last post by  bsmuwk
After some pointers, Started my 230te today, (hasnt been run for some time), it fired first turn of the key, when I touched the throttle, it cut out and now wont start. It has no spark

Have tried the following:
Checked, removed the ovp relay all ok
Fuel pump priming ok
Took king lead off coil earthed it, no spark
Coil reading 13.4v on pos -.15 on neg on ignition live, but replaced it anyway

Still no spark
Trying to recall on the early edis it does need a signal from CPS, next question is are they prone to failure, how to test and where are they.

Also if anyone knows if no spark is a common problem caused by something else.

The number 4 hammer will be coming out soon.....
1 - 2 of 4 Posts
We have ignition!!!

Removed all fuses and relays, cleaned them up, cleaned earths up and removed, strip and cleaned dizzy.

Sparking lovely now
1 - 2 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.