Mercedes-Benz Forum banner

21 - 28 of 28 Posts

·
Registered
Vito 114 tourer 2015: Vito 108d 97: 108d 98: Traveliner 2003 ; Aixam; z1100; xbr500; z440 ++++
Joined
·
2,390 Posts
from what you say, its the blower itself.

luckily they are easy to find at breakers..... only fly in the ointment is that its awkward to get to the cable connections (on the blower controls)

I got someone a blower fairly cheap by cutting the blower cables near the central console (on the replacement) so that it came out with almost no work..... his old blower was then cut off near the motor and the cables rejoined when fitted.

it would seem an odd way to do it but the swap took less than 15minutes total and the breaker let it go cheaply as he didn't have to spend a lot of time removing it.

note... the blower ALWAYS goes through a resistor, even on full power, so don't run one directly from the battery for too long
 

·
Registered
Vito 110 CDi '99
Joined
·
49 Posts
from what you say, its the blower itself.

luckily they are easy to find at breakers..... only fly in the ointment is that its awkward to get to the cable connections (on the blower controls)

I got someone a blower fairly cheap by cutting the blower cables near the central console (on the replacement) so that it came out with almost no work..... his old blower was then cut off near the motor and the cables rejoined when fitted.

it would seem an odd way to do it but the swap took less than 15minutes total and the breaker let it go cheaply as he didn't have to spend a lot of time removing it.

note... the blower ALWAYS goes through a resistor, even on full power, so don't run one directly from the battery for too long
It's just a case of removing that middle dash panel and a couple screws on the switch bit isn't it? Or do you mean the cables at the blower end?

I'm seeing new ones on ebay for £50, I've not bought anything from a scrappy before, is it likely to be less than that?

Thanks :)

http://www.ebay.co.uk/itm/Heater-Blower-Motor-for-Mercedes-Benz-Vito-638-1996-2003-/380823491620?pt=UK_CarsParts_Vehicles_CarParts_SM&fits=Model:Vito|Plat_Gen:638&hash=item58aad95424

Seems pretty cheap!
 

·
Registered
Vito 114 tourer 2015: Vito 108d 97: 108d 98: Traveliner 2003 ; Aixam; z1100; xbr500; z440 ++++
Joined
·
2,390 Posts
yup..... its remove the central dash panel... take the radio out... 2 screws in top vents... 1 under radio and sometimes another couple near the gear change.....

depending on the gear change cover (gaiter or ball) this is verying levels of complexity...

then 2 screws in each end of the controller and out it comes.

the blower itself is held in with 3 screws... but you know that

the bit with the cable cutting was an easy method and a couple of minutes total... this meant the breaker let it go for a fiver as there was no work as far as he was concerned.

fans do not go that often.. its the other bits that cause problems
 

·
Registered
Vito 110 CDi '99
Joined
·
49 Posts
shooooooould be fairly straight forward then :) I removed all that before so fairly familiar, and put a new gear knob on so know the score with that too! I'm very excited! Hopefully won't have to demist my windscreen manually anymore haha
 

·
Registered
Vito 114 tourer 2015: Vito 108d 97: 108d 98: Traveliner 2003 ; Aixam; z1100; xbr500; z440 ++++
Joined
·
2,390 Posts
we got was £10 but that might be pure luck.

I would certainly hope they are cheaper than £50.....

luckily I have a spare if mine goes.... £50 seems a lot to me but vito spares aren't cheap.

you will see from my vehicles that I'm on my third and I'm using the old ones as my spares but I don't really have "extras"

what I did was to scan vito ads when I cannot sleep (I live on medication and it has side effects) and put in "silly" bids when nobody else is bidding.....

my best buys were during the last world cup... 3 side doors, 2 front doors, a full set of bumpers and a pair of front wings... all for under £40 total...

I did however drive from lancashire to birmingham then up to doncaster and home in order to collect them.... took all day and I don't know how many miles but I really did come out in front.... the 4 doors will go on the traveliner and I'll still have the wings for when they're needed.

oh yes.... and I got a brand new bonnet and a power window mechanism for £10 each from a local mb main agent..... the roof had been damaged in a gale and the stock was thoroughly wet.... they got insurance to replace everything and sold the complete stock of spares at scrap prices (complete with mb guarantees).... unfortunately they were mb cars and only had a few vito bits... but I got my neighbour a new bonnet for his c class and he paid for my bits for my bringing it back.

my advice is to always look, I will consider myself lucky if I never use the spares but they're here if needed......

oh yes.... its worth making silly offers on ebay items as many will sit on the site for months if not years.

malcolm
 

·
Registered
Joined
·
8 Posts
Hiya. Just wanted to share results after reading this thread.

Symptom:
Blower only works in 4th.
With rest heat activated blower will only work in setting 4.

Bought a new resistor pack on ebay and that did it, real easy to replace too with the infomation in this thread.

Thanks for sharing!
 

·
Registered
2008 vito 109cdi
Joined
·
24 Posts
blower issue on a 109 w639 2008

Hi everyone,

In my case the blower works fine in 1 2 and 3. When using 4 or 5 the blower fails after about a couple of seconds. After that 1,2 and 3 are not working either. Setting it back on 0, and waiting a minute or so, i can start over and let it work on 1, 2 and 3 without failing.

After reading this thread, can i conclude that in my case it is the motor resistor pack and not the blower motor? Or is it possible that one fan is not working since i noticed the W639 has two fans on the motor?

Is there anything else i should check apart from also the pollenfilter?

best regards,
nicolaus
 

·
Registered
2008 vito 109cdi
Joined
·
24 Posts
Today 4 and 5 also failed. afterwards i could turn it on on 5 for a couple of seconds before it died of again. After disassembling i found the cause: worn out carbon brushes. I put a second hand blower in and everything works fine again.

Best regards,
nicolaus
 
21 - 28 of 28 Posts
Top