Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
Vito 109 SWB 2.1 diesel (w639)
Joined
·
10 Posts
Discussion Starter #1
Hi I am new to the forum and have only had my Vito van for 5 months like most wanted a VW but could not afford one.
Everything has been fine with the van until the first time the temp dropped below 5c then things start to go down hill. Firstly neither key fob would open the van so I changed the batteries in both still no luck, so had to revert to using manual key on n/s front door which then would activate the aftermarket cobra alarm. After a couple of times of the alarm going off (and a lot of curtains moving) I would be able to open van with remote. So thinking it was the alarm I stopped locking the van at night with the remote and just used the key. This seemed to be working for a while so because money is very tight I would put up with getting in via n/s but now it’s even colder remote still not working to unlock van but now the key will not unlock motorised steering lock so unable to start.
Has anybody any ideas.
 

·
Registered
Vito 3.0 V6 Silver
Joined
·
74 Posts
Cold weather normally exposes a duff battery, and by battery I mean the main one located under the passenger seat. I'd be inclined to get a new battery for the van and then problem solve from there.
 

·
Registered
2000 Vito 110CDI (never should have sold it), Current project 1999 V220 Ambient
Joined
·
379 Posts
is it just the moisture in the lock mechanism freezing and jamming the locks?
 

·
Registered
Vito 109 SWB 2.1 diesel (w639)
Joined
·
10 Posts
Discussion Starter #5
I can get into the van OK with the emergency manual key I can then press the central locking button on the dash and all the doors unlock.
The only thing that does not seem to work is the key fob when you place it into the ignition slot I do not hear the steering lock releasing and so I cannot turn the fob to start the engine. I have also noticed today the digital odometer is not show the mileage only - - - - - - - - - - the time is still visable....
 

·
Registered
Joined
·
296 Posts
Its the EZS ( Thing you put the key into) That picks up the remote transmission.

Test your keys by putting your phone on camera and pressing the buttons facing the camera! you should see a infa red light shining!

Its probably the EZS tho! around £400 from a dealer, plus fitting etc.
 

·
Registered
Vito 109 SWB 2.1 diesel (w639)
Joined
·
10 Posts
Discussion Starter #7
Funny you saying that I called out recovery to have a look as I needed to know for Monday he got the van going by inserting key fob into ignition several times the system then unlocked. He had been speaking to someone on his technical team and they informed him MB has a recall out on some Vito ignitions systems (EZS). Suggested I give them a call to see if my van is included (fingers cross).
 

·
Registered
Joined
·
3 Posts
Hi pal had the same problem with my steering lock not coming off. I had the breakdown come to it. He removed the ignition barrel been sure to remove the key first, then unplugged all the wires off it, tapped it with a screwdriver a couple of times then put it back together. Its worked ever since. Apparently its some sort of reset
 
1 - 8 of 8 Posts
Top