Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi to everyone,

I have Mercedes Vito 2.2 108cdi,2001 year,and problem with EDC warning light,engine shut of on 3500 rpm when I drive..no error codes stored in ECU...think it is a problem with CPS(cluch pedal position sensor)..because when I press two times clutch pedal then engine dont shut off on 3500 rpm when I drive...but I think maybe is problem not in him,then in ECU software? any help?

Thx

Regards

Neven from Croatia
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
Correction:

the same happen´d when I drive in third gear(3) engine shut off even I press clutch pedal twice.... when I´m in second gear theh this dont happen´d engine goes more them 3500 rpm...
why this have metter with in witch gear I am??
so clutch pedal sensor is okey...what is then?
 

·
Registered
Joined
·
80 Posts
you need to check the rail pressure and see if its dropping at the higher rpm. could be an injector starting to fail also
 

·
Registered
Various...110 Vito reason for joining right now
Joined
·
11 Posts
Hello Neven

Until 1/2 an hour ago I had the same problem with a 110, 1999 CDI. It is the computer forcing the car into Limp Mode...to protect the engine from damage. Mine was because of turbo overboosting, caused by a faulty turbo boost control valve. I followed lots of advice from this and other forums - car got better and better - but finally cured the problem with the help of a mechanic with a very good computer that talked to mercedes' computer properly...not like my cheap one!

Check for a vacuum leak first. All around engine, under car (rhs front wheel arch in uk) at turbo and believe it or not on the headlight adjuster switch and headlamps (if fitted) Check all the wires and plugs. If you can get the codes read first to show you where to concentrate...but make sure the machine is a good one.

Good luck!
John
 
1 - 7 of 7 Posts
Top