Mercedes-Benz Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter #1
Hi all Mercedes enthusiasts:

I have a question regarding ViseeO Bluetooth Adapters MB-2 or MB-3

I have Mercedes phone systems which support exchangable cradles (known as UHI or MHI). I want to purchase ViseeO Bluetooth Adapter, but don't know which one to go with MB-2 or MB-3 for my CLS 55 2006

I want to be able to play Pandora music via Bluetooth through command console. Is it possible with Iphone 4S?

I am sure many people have similar needs :)
 

·
Registered
Joined
·
3,294 Posts
I don't know the answer to your question but I can tell you this, my Viseeo MB2 is a PIA.
Some times it connects to the phone in my pocket straight away and other times I have to press the reset button or occasionally unplug it and plug it back in.
It's annoying me that much I'm going to look into a genuine Mercedes bluetooth adaptor, because if I forget to check it's connected and it hasn't and the phone rings I may as well not have it. I have to get my phone out of my pocket which defeats the object of the Viseeo.
 

·
Registered
Joined
·
51 Posts
Discussion Starter #3
Thank you SHAUNE55 for the information and that is not a good behavior and would annoy me too. I heard genuine Mercedes bluetooth adaptor software is not updatable and that is one of the drawbacks of it.

I need to play music via command console and want the easy way out. Right now using FM Stereo streaming via 12V connector, but tired of seeing cords hanging around :)
 

·
Registered
Joined
·
3,294 Posts
The MB 2 comes with a lead to plug into the PC to update it but I couldn't get it to work, however I only gave it a quick try once.
I'll have a look for the instructions and see if it mentions music.
 

·
Registered
Joined
·
51 Posts
Discussion Starter #5
The MB 2 comes with a lead to plug into the PC to update it but I couldn't get it to work, however I only gave it a quick try once.
I'll have a look for the instructions and see if it mentions music.
About your issue not connecting automatically I found the following:

Q: The phone won't pair when I return to my car.
A: You need to ensure that the pairing on the phone is set to 'trusted' or 'pair without asking for a passcode' - on most recent phones this is the default but not always. Also, delete any unused pairings from in the phone.

Also the following web site has many good information about ViseeO and other MB options:

ViseeO Bluetooth Adapters for Mercedes
 

·
Registered
Joined
·
3,294 Posts
Cheers, I only have the MB2 paired and my phone set to pair automatically with the MB2, funny thing is that when I turn my ignition on my phone beeps and pairs with the MB2 straight away.
The cluster says no phone even though my phone says paired, when it works correctly the cluster says Viseeo, so it could be the phone...However like I said sometimes pressing reset on the MB2 solves it or unplugging MB2 solves it. That leads me to believe it's the MB2 that is the problem.
Still looking for the instructions to see if it mentions music, I'm terrible for putting things away and then forgetting where I put them!
 

·
Registered
Joined
·
51 Posts
Discussion Starter #10
Just found it in the glove box, it doesn't mention anything about music.
I find out that the ViseeO MB-3 has a built-in FM transmitter with 3 memory channel to allow broadcasting the A2DP/iPod/iPhone/AUX-IN music to car radio, but is about $450. Will see if that is any good maybe. Thanks again for looking up.
 

·
Registered
Joined
·
9 Posts
I've been having the same issues... and now the volume is so low I can barely hear anything. I'm in the process of sending it back to Cartronics (at my shipping costs which doesn't impress me much) for a fix or replacement.

Has anyone had much success with the OEM MB device? I'm not worried about the cost difference, I just want a system that will automatically connect and be reliable.

I don't know the answer to your question but I can tell you this, my Viseeo MB2 is a PIA.
Some times it connects to the phone in my pocket straight away and other times I have to press the reset button or occasionally unplug it and plug it back in.
It's annoying me that much I'm going to look into a genuine Mercedes bluetooth adaptor, because if I forget to check it's connected and it hasn't and the phone rings I may as well not have it. I have to get my phone out of my pocket which defeats the object of the Viseeo.
 

·
Registered
Joined
·
790 Posts
SHAUNE55 - I would say you have a bad one… we have been the sole North American distributor for a long time now of the MB2, and I can tell you that is NOT normal behavior. Mine, and the thousands we have sold are very reliable. I would send it back to your distributor and get a new one.

I can also tell you the MB3 is not ready for prime time. We try not to sell it, unless a customer demands.

There are better solutions for streaming audio (for less money too) like our ANystream or StereoStream.
 

·
Registered
Joined
·
9 Posts
Thanks. I am in the process of sending it back to Cartronics today. Although admittedly frustrated that I have to incur the shipping costs to do so. I'll update the forum on how I make out with a replacement.

SHAUNE55 - I would say you have a bad one… we have been the sole North American distributor for a long time now of the MB2, and I can tell you that is NOT normal behavior. Mine, and the thousands we have sold are very reliable. I would send it back to your distributor and get a new one.

I can also tell you the MB3 is not ready for prime time. We try not to sell it, unless a customer demands.

There are better solutions for streaming audio (for less money too) like our ANystream or StereoStream.
 

·
Registered
Joined
·
3,294 Posts
Thanks. I am in the process of sending it back to Cartronics today. Although admittedly frustrated that I have to incur the shipping costs to do so. I'll update the forum on how I make out with a replacement.
Did you ever try the update and if so what happened?
 

·
Registered
Joined
·
3,294 Posts
I assume this is Cartronics UK? If so, they are not related to us... Cartronics.com
I didn't get mine from either.
Do you think I should do the CPU and software update?
The last couple of days it's been working fine all day after a reset but then the next day it needs resetting again, then it's OK all day.
 

·
Registered
Joined
·
790 Posts
It may, the problem is there are counterfeit units out there. For instance, we are the only authorized dealer in North America. Medea is authorized for UK (there may be others). So it is important that you get it from an authorized source to make sure you are not getting a counterfeit.
They ARE NOT authorized to be sold on eBay. Most all those are counterfeit.
 

·
Registered
Joined
·
8 Posts
Have you tried the MB-4?

Just like to spread the word about the Viseeo MB-4, and specifically the excellent technical support available from the manufacturer in Taiwan.

I bought an MB-4 from an eBay shop but started having intermittent problems with it soon after first trying it. As I didn't know if it was the car or the MB-4 I wasn't going to send the MB-4 back straight away without a little investigation.

Amongst other things I logged a support e-mail on Viseeo's website but I didn't really expect an answer as they're in Taiwan and I rarely receive good support from far eastern manufacturers. However to my surprise I did get a response. My issue was obviously something they were interested in as the sender had copied various other people in Viseeo and had included a beta version of some new firmware to try.

After several e-mails back and forth and trying different things unsuccessfully, Viseeo said they'd contact my eBay seller to arrange for an exchange. Again, I wasn't 100% expecting them to follow this through so I contacted the eBay seller myself, only to find that Viseeo had already done what they'd promised and primed the seller that I'd be sending them my unit back.

I've now got a new one and it works perfectly.

Just wanted to share my good experience.....
 
1 - 20 of 24 Posts
Top