Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
188 Posts
Discussion Starter #1
So yesterday I replaced the blower resistor and prior to installation, I removed the positive terminal from the battery. Later that day I noticed that the auto-up/down function in the second stage of the window switches stopped working on ALL of the windows.. What the heck?

Any ideas?
 

·
Registered
Joined
·
188 Posts
Discussion Starter #2
So yesterday I replaced the blower resistor and prior to installation, I removed the positive terminal from the battery. Later that day I noticed that the auto-up/down function in the second stage of the window switches stopped working on ALL of the windows.. What the heck?

Any ideas?
Gonna try this, found on another forum...

"Press switch to raise windows fully and hold for about 5 secs , then drop window and hold switch again."
 

·
Registered
Joined
·
406 Posts
Not sure why you would remove the positive terminal instead of the negative but holding the switch it should work eventually. W140 windows are dicky when it comes to the resetting the auto feature.
 

·
Registered
Joined
·
188 Posts
Discussion Starter #4
Not sure why you would remove the positive terminal instead of the negative but holding the switch it should work eventually. W140 windows are dicky when it comes to the resetting the auto feature.
Duh, NEGATIVE, yes... Windows work again, first try. guess I got lucky!
 

·
Moderator
Joined
·
4,769 Posts
Windows acting funny are completely normal right after battery replacement and happens on most models including BMWs. Just need to cycle it. I believe its mentioned in the manual
 
1 - 6 of 6 Posts
About this Discussion
5 Replies
4 Participants
glepore
Mercedes-Benz Forum
BenzWorld.org forum is one of the largest Mercedes-Benz owner websites offering the most comprehensive collection of Mercedes-Benz information anywhere in the world. The site includes MB Forums, News, Galleries, Publications, Classifieds, Events and much more!
Full Forum Listing
Top