Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
2003 CLK430
Joined
·
7 Posts
Discussion Starter #1
I have a 2003 CLK430. The variable wiper sometimes works properly and sometime works as if on continuous low speed. Where is the infrared sensor located? If I turn the wiper off and then bac on it seems to reset and work properly for awhile. It then goes right back to continuous low speed. Any ideas as to what is going on? Has this been a problem on this model?
 

·
Registered
CLK 320
Joined
·
1 Posts
The location of the sensor is in the center of the windshield at the top (area above rea...

The location of the sensor is in the center of the windshield at the top (area above rearview mirror)

The sensor will get fooled if the wiper leaves smeared marks on the glass. When that happens it will go into continous operation until the glass is relatively clear.

The sensor shoots an IR beam through the glass and the receiver determines how much water droplets are on the glass to determine the next wiper sweep.

The stock Bosch wiper rubber doesn't hold up (or age very well) - I had the smeary vision problem and replaced the wiper insert myself after just 3 weeks of taking delivery - it was that bad. I couldn't see driving at night!
 

·
Registered
Joined
·
387 Posts
Hal's right - after a little use the stock wiper sucks. Replace it with a silicone based w...

Hal's right - after a little use the stock wiper sucks. Replace it with a silicone based wiper like the ones offered by PIAA. There's cheaper alternatives as well...
 
1 - 3 of 3 Posts
Top