Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
I am having a sligh problem in a 93 400sel. The pump works fine, it just when I unlock the doors, it seems as if air escapes on the left rear door near the wheel. I thought it was a leak, but it is not close to the door lock. Also, when i turn the car off, the pump sounds like it is working for about 15 seconds. Happens everytime. I looked at the posts on adjusting the screw on the pump, but is is not the same as the one in the trunk that was shown. Any ideas?
 

·
Premium Member
1997 S600 (sold)
Joined
·
4,660 Posts
Yes, the closing-assist pump is in the trunk. You're dealing with the

PSE (pneumatic system equipment) pump. I'm a little confused. You say you hear an air leak from near the wheel, but you comment on the door. Where is the sound coming from exactly? You say left side door. But, I'm thinking it could be the fuel filler door lock since you say it's near the wheel but not the door lock. The only thing is the fuel filler door is on the right side of the car. By right side, I'm referring the the passenger side in a US car. Did you get right and left mixed up? The fuel door locks and unlocks just like the passenger doors. More than one person has had the actuator on the fuel filler door lock spring a major air leak. A new actuator solved the problem.

This pump is also responsible for the reverse rods on cars that have them, so it does have lines that go to the rear of the car. I don't know where they run exactly. Maybe one of these has sprung a leak.

Brett
 

·
Registered
Joined
·
32 Posts
Discussion Starter #3
i noticed in my vacum block in the passenger footwell, a black tube broke off. Could this have somethink to do with it? Can i fix it myself or do i havr to go to the dealers. The hiss comes from the driver rear door handle, only when unlocked. The pump still continues to function after the car is off.
 

·
Premium Member
1997 S600 (sold)
Joined
·
4,660 Posts
I would recommend going to www.alldatadiy.com and buying

a subscription for your car. It's US$25 very well spent. Or pick up a copy of the W140 CD (around US$150-200 from various places).

I believe the PSE pump does supply vacuum to the "block" for operation of various climate control functions when the engine isn't providing vacuum. But you don't say if the broken line is fed from the PSE pump or if you have air escaping there. I don't know whether this is relevant.

The hiss in the door is apparently an air leak. You'll just have to dig into the door and find it.

Brett
 

·
Registered
Joined
·
32 Posts
Discussion Starter #5
I found my leak. The left driver rear door leaks at the actautor connection with the yellow wire. The acuator itself does not seem to leak. The connection on the wire seems to be good, but air escapes. It escapes less when i put my finger over it. What do i need to replace?

As for the pump, I notice the vacum distribution block has one broken connection. It is # 12, A black and grey wire which Alldata says is a "2nd selection program automatic transmission (reservoir)" I doubt the piece that broke off the block and is still in the plug can be repaired. Can I hook that wire into another available spot on the block? I notoce some open connections have an x in them on the block, as did the spot that broke off. Can i use one of those or do i need a new block. What is that switch doing for the tranny anyway?
 
1 - 5 of 5 Posts
Top