Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
E350 2010
Joined
·
13 Posts
Discussion Starter #1
I have 2004 e320 with the v60 cradle. I have had the phone installed for about 4 years, since I bought the car. On and off I have problems with the phone not "activating" and/or Insert phone. Recently I notice the phone battery was swollen and I replaced it.

The problem seems to be lessened but not eliminated when I clean the phone and cradle contacts with rubbing alcohol.

Getting tired of this.

Thinking I should get a puck. But the main question is if the contacts on the cradle are bad will it work any better with the puck? Hate to spend the money on the puck to find out it is the cradle that is defective.

Thanks for any input you can provide.
 

·
Registered
Lots of collector cars from the 50's to present
Joined
·
288 Posts
04 was a problem year

Don't get worked up just get rid of the 04 one year only First GEN MOST were know for these problems. I sold my 04 CL 500. Let someone else deal with it. It would lock up completely, the radio would stop no sound. I would have to cut the car off and wait and sometimes disconnect the battery to reset the entire unit. Worst system EVER! I tried the puck NOTHING worked right, I used the V60 as well. That phone was great on my 06 CL. So, I can promise you its the unit car. You might try and use a cradle eliminator with the pig tail and do away with your connections but im telling you now, it is a known issue
 
1 - 2 of 2 Posts
Top